summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-06-07 08:52:55 +0200
committerAgostino Sarubbo <ago@gentoo.org>2021-06-07 08:52:55 +0200
commit10489c6c142fddeef5b8584c9f84a15fa0b2f56e (patch)
treee1b7607745951e414847009543104d80e9fd15f3 /app-admin
parentapp-admin/exo: version bump to 1.31.0 - remove old. (diff)
downloadgentoo-10489c6c142fddeef5b8584c9f84a15fa0b2f56e.tar.gz
gentoo-10489c6c142fddeef5b8584c9f84a15fa0b2f56e.tar.bz2
gentoo-10489c6c142fddeef5b8584c9f84a15fa0b2f56e.zip
app-admin/hcloud: version bump to 1.23.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/hcloud/Manifest1
-rw-r--r--app-admin/hcloud/hcloud-1.23.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/hcloud/Manifest b/app-admin/hcloud/Manifest
index b5e5c744f8e5..53787caf2778 100644
--- a/app-admin/hcloud/Manifest
+++ b/app-admin/hcloud/Manifest
@@ -1 +1,2 @@
DIST hcloud-1.22.1.tar.xz 910672 BLAKE2B 51e18c530964677bd0cef8232c68031f3186b83fe0da91e8c6572b95130df32e5b00de6e734fb6cce56a51b6fca6136bb306d33ad4a6c728aac3d0afe634c738 SHA512 365823e779f526ae9cbbb50ecaed557c5a838b6614208e4d03e7eadb9569a2e2156e05e019aea2623a811defda707b8822d0eb09a4bfd7006262bd6a19e09aae
+DIST hcloud-1.23.0.tar.xz 1129416 BLAKE2B b91e0a5f24020cd250a0e50c4c2b049397575e884968652f6795e89340a90f43141deee7179944e2027992f6f722a75704c3cb8fb0b0e0653036e9b5c34258d4 SHA512 d16d5eb28873045ba1ed0b09a6a76b26c3e39fffd404fca233d79640c06cb75fe2a13db22d9c343890bfb5ebac0535c7e7fae8e37e96229ddd5d324b2a9d4c79
diff --git a/app-admin/hcloud/hcloud-1.23.0.ebuild b/app-admin/hcloud/hcloud-1.23.0.ebuild
new file mode 100644
index 000000000000..77d54006fe99
--- /dev/null
+++ b/app-admin/hcloud/hcloud-1.23.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A command-line interface for Hetzner Cloud"
+HOMEPAGE="https://github.com/hetznercloud/cli"
+SRC_URI="https://dev.gentoo.org/~ago/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-w -X github.com/hetznercloud/cli/cli.Version=${PV}-gentoo" ./cmd/${PN} || die "build failed"
+}
+
+src_test() {
+ # For upstream a simple test is run 'hcloud version'
+ ./hcloud version
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}