summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2017-11-18 12:45:37 +0100
committerDaniel Pielmeier <billie@gentoo.org>2017-11-18 12:46:00 +0100
commit130b50cbf5d0e6093dfdb8fd7d60e5c9e9f999d7 (patch)
tree368a950da2fb143be884fc2ec86af12564e0eafb /app-admin
parentdev-util/debhelper: Old. (diff)
downloadgentoo-130b50cbf5d0e6093dfdb8fd7d60e5c9e9f999d7.tar.gz
gentoo-130b50cbf5d0e6093dfdb8fd7d60e5c9e9f999d7.tar.bz2
gentoo-130b50cbf5d0e6093dfdb8fd7d60e5c9e9f999d7.zip
app-admin/conky: Fix bug 556480.
Thanks to devsk for the patch and report. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/conky/conky-1.10.6-r4.ebuild (renamed from app-admin/conky/conky-1.10.6-r3.ebuild)1
-rw-r--r--app-admin/conky/files/conky-1.10.6-cpu-hotplug.patch23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-admin/conky/conky-1.10.6-r3.ebuild b/app-admin/conky/conky-1.10.6-r4.ebuild
index 2f866b427285..0f6c02c40c02 100644
--- a/app-admin/conky/conky-1.10.6-r3.ebuild
+++ b/app-admin/conky/conky-1.10.6-r4.ebuild
@@ -77,6 +77,7 @@ PATCHES=(
"${FILESDIR}"/${P}-new_graph-oor.patch
"${FILESDIR}"/${P}-gcc-7.patch
"${FILESDIR}"/${P}-fix-text-shades.patch
+ "${FILESDIR}"/${P}-cpu-hotplug.patch
)
DISABLE_AUTOFORMATTING="yes"
diff --git a/app-admin/conky/files/conky-1.10.6-cpu-hotplug.patch b/app-admin/conky/files/conky-1.10.6-cpu-hotplug.patch
new file mode 100644
index 000000000000..16adbd8a6908
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.6-cpu-hotplug.patch
@@ -0,0 +1,23 @@
+From 7d2639e9c489c34fa9673fcaee8deec46043fbf8 Mon Sep 17 00:00:00 2001
+From: Daniel Pielmeier <billie80@users.noreply.github.com>
+Date: Sat, 18 Feb 2017 16:55:35 +0100
+Subject: [PATCH] Fix SEGV in a CPU hotplug environment #127
+
+---
+ src/linux.cc | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/linux.cc b/src/linux.cc
+index 664ddf5e..63b3ea40 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -900,6 +900,9 @@ int update_stat(void)
+ } else {
+ idx = 0;
+ }
++ if (idx >= info.cpu_count) {
++ continue;
++ }
+ sscanf(buf, stat_template, &(cpu[idx].cpu_user),
+ &(cpu[idx].cpu_nice), &(cpu[idx].cpu_system),
+ &(cpu[idx].cpu_idle), &(cpu[idx].cpu_iowait),