summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 14:53:23 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-25 18:18:20 +0100
commit6cf5c3067a6123cc493593fa37294c3f86522aa0 (patch)
tree752c184bc4396fda84492bfeebf8e69af83f18a1 /app-admin
parentdev-ml/ppx_expect: Stabilize 0.15.1-r1 ppc64, #901561 (diff)
downloadgentoo-6cf5c3067a6123cc493593fa37294c3f86522aa0.tar.gz
gentoo-6cf5c3067a6123cc493593fa37294c3f86522aa0.tar.bz2
gentoo-6cf5c3067a6123cc493593fa37294c3f86522aa0.zip
app-admin/ansible-molecule: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild9
2 files changed, 3 insertions, 8 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index a927a79ed492..519b6758a9f7 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,2 +1,2 @@
DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
-DIST ansible-molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
+DIST molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
index 15dd9cdede34..0960805c1e45 100644
--- a/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
+++ b/app-admin/ansible-molecule/ansible-molecule-4.0.4.ebuild
@@ -6,15 +6,12 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="molecule"
-inherit distutils-r1 optfeature
-
-MY_PN="${PN#ansible-}"
-MY_P="${MY_PN}-${PV}"
+inherit distutils-r1 optfeature pypi
DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -56,8 +53,6 @@ BDEPEND="$(python_gen_cond_dep '
)
')"
-S="${WORKDIR}"/${MY_P}
-
# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
# - quite a few of these tests use the network;
# - test_command_dependency[shell] only works if Molecule has previously been installed;