summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-25 03:17:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-25 04:02:24 +0200
commit80bdf643f22cae167ea58e17b7c66b6d251f6786 (patch)
tree8b0f9ac6494836392cfe06bd28ab2ec44cedf579 /app-admin
parentdev-python/boto3: Bump to 1.26.119 (diff)
downloadgentoo-80bdf643f22cae167ea58e17b7c66b6d251f6786.tar.gz
gentoo-80bdf643f22cae167ea58e17b7c66b6d251f6786.tar.bz2
gentoo-80bdf643f22cae167ea58e17b7c66b6d251f6786.zip
app-admin/awscli: Bump to 1.27.119
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.119.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 5655379a5dd9..633e0c4dbced 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,2 +1,3 @@
DIST aws-cli-1.27.114.gh.tar.gz 2406530 BLAKE2B a566214d83d0238c74e306d82829bc9a512aa03def8a4f3ccffc819ded588427051c524fbd91c32f1dd6f6eafd54e6fe40a1e701c9985a1ec587f362fe1c2920 SHA512 60df892a996b5b5c36478e86f321ae9abe3c2d3faafc3187d0b9442d060633ddeddbeeab7ee42a0eca7cb45b07f8c86bbf9d626362a26c503f10b1c693dd1f2a
DIST aws-cli-1.27.118.gh.tar.gz 2410453 BLAKE2B 75bf42c439c9fc0e16c1a3e919d4c6b8c9246c754eb0ba485c4ec193e6b4e0e3de60eff7c433937b31997ba7d26eef622a382b41d107139de36f5475ae083a6f SHA512 036262c1c3731a5f8b6704ad278ea53f3ae5810b18fd8d4b93ba26c1c17eba79180f8310a40427332e24a4f42ac47e2707ccd4e5d28b29ab4f4593d6820cc4d9
+DIST aws-cli-1.27.119.gh.tar.gz 2411159 BLAKE2B 7730da312c27cb99bf8a9b135164fe89083e65d522e98e1b9ebd6730174dc82c113d8fe39ee27d01d8e1abcdb878fd5b3b9bf91160b20a02d4724a1673b9c4e8 SHA512 884907dc6dbe324fa68fb1bb6de2a033522adf21e36bae999aa1206492c5df25e569a4d35304b08013b425c059eb1b235d8c30329da951953d2e562d495618af
diff --git a/app-admin/awscli/awscli-1.27.119.ebuild b/app-admin/awscli/awscli-1.27.119.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.119.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}