summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 07:32:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 08:43:59 +0100
commita9f547d527a92e405853b5eab3a0288444e97678 (patch)
tree63df81f6c22aa74d48a2931635ec17572cc31c8c /app-admin
parentdev-python/boto3: Bump to 1.33.2 (diff)
downloadgentoo-a9f547d527a92e405853b5eab3a0288444e97678.tar.gz
gentoo-a9f547d527a92e405853b5eab3a0288444e97678.tar.bz2
gentoo-a9f547d527a92e405853b5eab3a0288444e97678.zip
app-admin/awscli: Bump to 1.31.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.31.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 4d8e767e6499..9cc1acc88efe 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.30.3.gh.tar.gz 2594517 BLAKE2B 67ffda10491b734a15119ed3963735e53a
DIST aws-cli-1.30.6.gh.tar.gz 2596217 BLAKE2B 3b4cbd540ede2826d212233e76a4431f090fdaa1848f3ddd5e52c3d637e8ccb6ed406072b5b4b3f62b67a29a995d984bfcf1f961915594459e52199dba2341b8 SHA512 8273d234428eb42e8845052c4122e06bb6d0693d2878296a101fa3ce72c5690787c6151aa8f819db83fe36f5263d14efd1e4b469494da8994d47d1f213c394b3
DIST aws-cli-1.31.0.gh.tar.gz 2599974 BLAKE2B 3ffc916e01cebd9e8532d01190324c3d8a51f13710751df530ab7ef24f759202bf41072367ffa871cf1a1c9d980d5bb4d5739fb9f5cc651e1e660a9684dad79d SHA512 d99497c945af03ac35fa19e6cce3b25b4cd13e5f7e84eef85bfd32bd9411d6ae0e41ca96117e2ea26c791b56cae19e4c92b742c83ef5cf5338f27ee287d78b8a
DIST aws-cli-1.31.1.gh.tar.gz 2600259 BLAKE2B ebe55d0b5cd1ba730ce4ef6b6911b5d4877668c04428d59dd75a353ac55ddea4a42296399b53ce4ed119fcd7b877762adbf606b0dd114274cf4c68186577d1c1 SHA512 96a97b585ad8b47394412ed4d1494414e70ddb52788da5c2e8e977652b5fde2300b2c98b0727f19e1f305ff5b55dd428049cdd6fd3fbc746a4aec28d68c25f9d
+DIST aws-cli-1.31.2.gh.tar.gz 2602541 BLAKE2B a24a6a4d7c5714e4d54d6eaa2e77a0a642a815f917951b0aea23a91da745f78e647543b47e656cb1ceb6a952552b498b7ae6f316763bfae34ec5e84789564699 SHA512 a0e0e88210ce9be19c66981a8a9def72f1032492cbb6075afd0c4f9c753d270b82925fc2428f81811a6bc8745a2dccb7c2e1ad2291969c2139a9a40915c48542
diff --git a/app-admin/awscli/awscli-1.31.2.ebuild b/app-admin/awscli/awscli-1.31.2.ebuild
new file mode 100644
index 000000000000..509293927af1
--- /dev/null
+++ b/app-admin/awscli/awscli-1.31.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.8.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}