summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/lha
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/lha')
-rw-r--r--app-arch/lha/Manifest1
-rw-r--r--app-arch/lha/files/lha-114i-file-list-from-stdin.patch29
-rw-r--r--app-arch/lha/lha-114i-r7.ebuild47
-rw-r--r--app-arch/lha/metadata.xml15
4 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/lha/Manifest b/app-arch/lha/Manifest
new file mode 100644
index 000000000000..0ac42288c532
--- /dev/null
+++ b/app-arch/lha/Manifest
@@ -0,0 +1 @@
+DIST lha-1.14i-ac20050924p1.tar.gz 285518 SHA256 b5261e9f98538816aa9e64791f23cb83f1632ecda61f02e54b6749e9ca5e9ee4 SHA512 efe43d407d273f8f724f7b205223bd122c76adac4b67ad5e9811e88cae03f1f3c3af4297aa6f24951a02558975bbafacf697e97ab0da578b4e0115b89237566f WHIRLPOOL 2aaa99fa8106423fea381b4ebe72e7a454008032be88420d9d92d8cda0c9e4f38857909d5e5f6fb0303db0311978eb2ca64ee0465beb9dc780a9f5be2218e774
diff --git a/app-arch/lha/files/lha-114i-file-list-from-stdin.patch b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
new file mode 100644
index 000000000000..4bd0d17d7527
--- /dev/null
+++ b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
@@ -0,0 +1,29 @@
+Index: src/lharc.c
+===================================================================
+--- src/lharc.c (revision 773)
++++ src/lharc.c (working copy)
+@@ -561,7 +561,7 @@
+ if (!isatty(1) && cmd == CMD_ADD)
+ quiet = TRUE;
+ }
+-#if 0 /* Comment out; IMHO, this feature is useless. by Koji Arai */
++#ifndef MINGW32
+ else {
+ if (argc == 3 && !isatty(0)) { /* 1999.7.18 */
+ /* Bug(?) on MinGW, isatty() return 0 on Cygwin console.
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 773)
++++ configure.ac (working copy)
+@@ -289,6 +289,11 @@
+ [Define to 1 if you want to ignore dot files with -X command line switch])
+ fi
+
++AC_MINGW32
++if test "x$MINGW32" = xyes; then
++ AC_DEFINE(MINGW32, 1, [Define to 1 if we're being compiled with MinGW.])
++fi
++
+ AC_CONFIG_FILES([Makefile src/Makefile man/Makefile olddoc/Makefile])
+ AC_CONFIG_FILES([tests/Makefile tests/lha-test])
+ AC_OUTPUT
diff --git a/app-arch/lha/lha-114i-r7.ebuild b/app-arch/lha/lha-114i-r7.ebuild
new file mode 100644
index 000000000000..dad79e2b7ade
--- /dev/null
+++ b/app-arch/lha/lha-114i-r7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils flag-o-matic
+
+MY_P=${PN}-1.14i-ac20050924p1
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="http://lha.sourceforge.jp"
+SRC_URI="mirror://sourceforge.jp/${PN}/22231/${MY_P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-file-list-from-stdin.patch
+
+ sed -i -e '/^AM_C_PROTOTYPES/d' configure.ac || die #423125
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -DPROTOTYPES #423125
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ econf
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ mandir="${EPREFIX}"/usr/share/man/ja \
+ install
+
+ dodoc ChangeLog Hacking_of_LHa
+}
diff --git a/app-arch/lha/metadata.xml b/app-arch/lha/metadata.xml
new file mode 100644
index 000000000000..8eb52056a1e2
--- /dev/null
+++ b/app-arch/lha/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>nitro@legroom.net</email>
+ <name>Jared B.</name>
+ </maintainer>
+ <longdescription lang="en">
+ A utility for creating and opening lzh archives.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge-jp">lha</remote-id>
+ </upstream>
+</pkgmetadata>