summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-12-20 02:49:47 -0500
committerAnthony G. Basile <blueness@gentoo.org>2016-12-20 02:50:20 -0500
commitd41052d32ded9415b1c8a3eb638af565990e7651 (patch)
treeace891588755dd0ca29e140901a3da3e1c406b49 /app-backup/borgbackup/borgbackup-1.0.9.ebuild
parentapp-emulation/libvirt: version bump (diff)
downloadgentoo-d41052d32ded9415b1c8a3eb638af565990e7651.tar.gz
gentoo-d41052d32ded9415b1c8a3eb638af565990e7651.tar.bz2
gentoo-d41052d32ded9415b1c8a3eb638af565990e7651.zip
app-backup/borgbackup: version bump to 1.0.9
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-backup/borgbackup/borgbackup-1.0.9.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-1.0.9.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.0.9.ebuild b/app-backup/borgbackup/borgbackup-1.0.9.ebuild
new file mode 100644
index 000000000000..065fdc13465b
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.0.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/borg.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption."
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl +fuse"
+
+# Unformately we have a file conflict with app-office/borg, bug #580402
+RDEPEND="
+ !!app-office/borg
+ app-arch/lz4
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ fuse? ( dev-python/llfuse[${PYTHON_USEDEP}] )
+"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"