summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-12-15 18:12:55 -0500
committerJoonas Niilola <juippis@gentoo.org>2023-01-09 15:13:03 +0200
commited8a2dd9300bb2be2ca91f8cb54fd4e88fb982fa (patch)
treee6c32587a3186925f729d03183804c9991cde198 /app-backup/mkstage4/mkstage4-0.4.ebuild
parentmedia-sound/musescore: hack to avoid collision from bundled libs (diff)
downloadgentoo-ed8a2dd9300bb2be2ca91f8cb54fd4e88fb982fa.tar.gz
gentoo-ed8a2dd9300bb2be2ca91f8cb54fd4e88fb982fa.tar.bz2
gentoo-ed8a2dd9300bb2be2ca91f8cb54fd4e88fb982fa.zip
app-backup/mkstage4: add 0.4
Signed-off-by: Horea Christian <chr@chymera.eu> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-backup/mkstage4/mkstage4-0.4.ebuild')
-rw-r--r--app-backup/mkstage4/mkstage4-0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-backup/mkstage4/mkstage4-0.4.ebuild b/app-backup/mkstage4/mkstage4-0.4.ebuild
new file mode 100644
index 000000000000..8ee6165dc03b
--- /dev/null
+++ b/app-backup/mkstage4/mkstage4-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bash Utility for Creating Stage 4 Tarballs"
+HOMEPAGE="https://github.com/TheChymera/mkstage4"
+SRC_URI="https://github.com/TheChymera/mkstage4/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-util/bats )"
+RDEPEND="
+ app-shells/bash
+ app-arch/tar
+"
+
+src_install() {
+ newbin mkstage4.sh mkstage4
+ newbin exstage4.sh exstage4
+ einstalldocs
+}
+
+src_test() {
+ bats tests/* || die
+}