summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-07-25 10:16:40 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-07-25 10:20:33 -0500
commit30a88a3dc73478b1935ce501838db87cc943ceee (patch)
tree9c007c27b0665a73be1cc41f8ed0f20f261884a7 /app-containers/containerd
parentapp-containers/docker-cli: drop 23.0.3, 24.0.4-r1 (diff)
downloadgentoo-30a88a3dc73478b1935ce501838db87cc943ceee.tar.gz
gentoo-30a88a3dc73478b1935ce501838db87cc943ceee.tar.bz2
gentoo-30a88a3dc73478b1935ce501838db87cc943ceee.zip
app-containers/containerd: drop 1.6.19
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/containerd')
-rw-r--r--app-containers/containerd/Manifest1
-rw-r--r--app-containers/containerd/containerd-1.6.19.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index dbe3f2ff593f..d845e0db4839 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,2 +1 @@
-DIST containerd-1.6.19.tar.gz 8706434 BLAKE2B cd6a85721f0752b6c7c5c098153d581375db6f877e261097a7d74a78dc0957e6beeea38c1aa7c53227ed84e727744811fa38863097cb137b8ba775e1f04fb9b2 SHA512 dca78d472dfbc6fc4d9b0b3a0d0a131d3575163c52e4fe18ea2c6147868b8822c54046c0709974e9b90472b882ba3890ada7f0fcbf31549efffba0d91531886c
DIST containerd-1.7.1.tar.gz 9682254 BLAKE2B f168070caf2b76f0be350a98f41bfdbfe6d78344d68821fb92a29f839a6e847d795e5b79436e36f985aa88028ff1c3f44f134cf6bd502ddac22453a457bd952b SHA512 e9b00ba8f4dd1b5b1088060d3822f684611d43b367ddfeb1bee1660140af85f31e9c9bfc600a67e8fc8645a625dc4e1919d9af7291bdeaa607bff7065a4fc945
diff --git a/app-containers/containerd/containerd-1.6.19.ebuild b/app-containers/containerd/containerd-1.6.19.ebuild
deleted file mode 100644
index ae8d1150aa07..000000000000
--- a/app-containers/containerd/containerd-1.6.19.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-GIT_REVISION=1e1ea6e986c6c86565bc33d52e34b81b3e2bc71f
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.io/"
-SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv ~x86"
-IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
-
-DEPEND="
- btrfs? ( sys-fs/btrfs-progs )
- seccomp? ( sys-libs/libseccomp )
-"
-
-# recommended version of runc is found in script/setup/runc-version
-RDEPEND="
- ${DEPEND}
- ~app-containers/runc-1.1.4
-"
-
-BDEPEND="
- dev-go/go-md2man
- virtual/pkgconfig
-"
-
-# tests require root or docker
-RESTRICT+="test"
-
-src_prepare() {
- default
- sed -i \
- -e "s/-s -w//" \
- -e "s/-mod=readonly//" \
- Makefile || die
- sed -i \
- -e "s:/usr/local:/usr:" \
- containerd.service || die
-}
-
-src_compile() {
- local options=(
- $(usev apparmor)
- $(usex btrfs "" "no_btrfs")
- $(usex cri "" "no_cri")
- $(usex device-mapper "" "no_devmapper")
- $(usev seccomp)
- $(usev selinux)
- )
-
- myemakeargs=(
- BUILDTAGS="${options[*]}"
- LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
- REVISION="${GIT_REVISION}"
- VERSION=v${PV}
- )
-
- # race condition in man target https://bugs.gentoo.org/765100
- # we need to explicitly specify GOFLAGS for "go run" to use vendor source
- emake "${myemakeargs[@]}" man -j1 #nowarn
- emake "${myemakeargs[@]}" all
-
-}
-
-src_install() {
- dobin bin/*
- doman man/*
- newconfd "${FILESDIR}"/${PN}.confd "${PN}"
- newinitd "${FILESDIR}"/${PN}.initd "${PN}"
- systemd_dounit containerd.service
- keepdir /var/lib/containerd
-
- # we already installed manpages, remove markdown source
- # before installing docs directory
- rm -r docs/man || die
-
- local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
- einstalldocs
-}