summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-01-25 20:55:22 +0530
committerZac Medico <zmedico@gentoo.org>2024-02-01 22:37:25 -0800
commit3ce5be3e30a8d60756b3685d1069788ec801f7f8 (patch)
tree33391fc088f4b3b3f2b93520d2a26c7791c0eb00 /app-containers/containers-image/containers-image-9999.ebuild
parentapp-containers/podman: add 4.9.1 (diff)
downloadgentoo-3ce5be3e30a8d60756b3685d1069788ec801f7f8.tar.gz
gentoo-3ce5be3e30a8d60756b3685d1069788ec801f7f8.tar.bz2
gentoo-3ce5be3e30a8d60756b3685d1069788ec801f7f8.zip
app-containers/containers-image: add 5.29.2
Cherry pick https://github.com/containers/image/commit/45441676e34e6410ae8af6dbb46b6161c5c81a7c because default.yaml and policy.json are moving from containers-common-0.57.3 to containers-image-5.29.2 Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-containers/containers-image/containers-image-9999.ebuild')
-rw-r--r--app-containers/containers-image/containers-image-9999.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/app-containers/containers-image/containers-image-9999.ebuild b/app-containers/containers-image/containers-image-9999.ebuild
index 7e9e9b9dad81..4fb96c1222c3 100644
--- a/app-containers/containers-image/containers-image-9999.ebuild
+++ b/app-containers/containers-image/containers-image-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,18 +12,15 @@ if [[ ${PV} == 9999* ]]; then
else
SRC_URI="https://github.com/containers/image/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P#containers-}"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
fi
LICENSE="Apache-2.0"
SLOT="0"
-BDEPEND=">=dev-go/go-md2man-2.0.2"
-
-src_prepare() {
- default
- eapply "${FILESDIR}/fix-warnings.patch"
-}
+# https://github.com/gentoo/gentoo/pull/35012#discussion_r1473740969
+RESTRICT='test'
+BDEPEND=">=dev-go/go-md2man-2.0.3"
src_compile() {
emake docs