summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-14 15:55:51 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-14 16:08:11 +0200
commitda34b0a25623648ddf5398c66af08e12d42cfcf4 (patch)
tree118302d7f85af43d7903c1052358bdca85840792 /app-containers/earthly
parentapp-containers/earthly: drop old 0.8.13 (diff)
downloadgentoo-da34b0a25623648ddf5398c66af08e12d42cfcf4.tar.gz
gentoo-da34b0a25623648ddf5398c66af08e12d42cfcf4.tar.bz2
gentoo-da34b0a25623648ddf5398c66af08e12d42cfcf4.zip
app-containers/earthly: drop old 0.8.14
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/earthly')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.14.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 01cc96748ada..c7c361bef9d7 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,4 +1,2 @@
-DIST earthly-0.8.14-deps.tar.xz 163777848 BLAKE2B 0615db6d874a0d490666df6517581763315c44a67662d1c8c630d59983849c3a1c10bdee4d626f9ded02a58f7eb037e24cca6b22dfc7eadf79d4e735a33306c5 SHA512 ac062ae77e98ec36f9bba1a73430080d2f2c7bed3ad8c48af8bb1da4a6f006a4285fca8f4d85363652ec3db9df78e76befdfc838971684d704512d795d672414
-DIST earthly-0.8.14.tar.gz 8079338 BLAKE2B c3da74c39b77f671656ba51f7e8a82b77476650e986e5665e1df86fd1674e808b79edcc0b8f616891b6749ec034de45268fb48df519c5fdf54c1e3e583eab5a6 SHA512 566e6bdd6f026baa99bad33128e3a843ef20dacc15efdccaf19af648440c8ee7b445bed80f33102b9fc419d211dc6dea38a66655247549f1eaf17837c6687105
DIST earthly-0.8.15-deps.tar.xz 163782812 BLAKE2B 09a9cb196206e787a48c2c2082a066a31c0bd8dba8785e379bfb86ac56ccf4f8eb34195c8577b866bc1153657008e4fae142eb7a6e21d2791fe92e9cdfa76e2d SHA512 65afc0bd89b6a54bb3e4cc4d7f39522eddbb79266b25afb33ffc3c6571b57952bc2ceafe00ce196098d1c4185ab2672f8a80d9ecd4d6d07dc06a18ba39da3941
DIST earthly-0.8.15.tar.gz 8102499 BLAKE2B 92793722206ab8c2d5bb097f7da40392d1ed1f3399797bc217dab7fcc0f305cc91f5e9f8b997b6e5e187f25c0f1109d8aba2294fb79d4b3f26d6660d36827d5c SHA512 0d98f716a2e2a6cb522abb42894f6356c12ac2e398382207db08d204dc951f65c7be04be7473e060c30a052768c4b2b7e9273d206b4252fec26975e6e166ae2a
diff --git a/app-containers/earthly/earthly-0.8.14.ebuild b/app-containers/earthly/earthly-0.8.14.ebuild
deleted file mode 100644
index c133e768eee1..000000000000
--- a/app-containers/earthly/earthly-0.8.14.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == "0.8.14" ]] ; then
- COMMIT_SHA="6b41f8409d7ffef0d25072c2c04250074b6e3c72"
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}