summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-16 14:38:41 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-16 14:38:41 -0500
commit6f1785ece38919185cade6114997235b8ef77b1f (patch)
treeb81451266136225fe191da2377c44a13ce75e8aa /app-containers/grype/grype-0.42.0.ebuild
parentmail-client/aerc: add 0.11.0 (diff)
downloadgentoo-6f1785ece38919185cade6114997235b8ef77b1f.tar.gz
gentoo-6f1785ece38919185cade6114997235b8ef77b1f.tar.bz2
gentoo-6f1785ece38919185cade6114997235b8ef77b1f.zip
app-containers/grype: add 0.42.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/grype/grype-0.42.0.ebuild')
-rw-r--r--app-containers/grype/grype-0.42.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-containers/grype/grype-0.42.0.ebuild b/app-containers/grype/grype-0.42.0.ebuild
new file mode 100644
index 000000000000..c98fb9fd7f0c
--- /dev/null
+++ b/app-containers/grype/grype-0.42.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/grype
+}
+
+src_install() {
+ dobin bin/grype
+}