summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-27 14:37:36 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-27 14:37:41 -0500
commit5abf39bdebe96fa45d301c52fcbc86ded2d50a50 (patch)
tree5b2c1566aed483fd8bf3baf67434080c6178f688 /app-containers/grype
parentapp-containers/syft: add 0.54.0 (diff)
downloadgentoo-5abf39bdebe96fa45d301c52fcbc86ded2d50a50.tar.gz
gentoo-5abf39bdebe96fa45d301c52fcbc86ded2d50a50.tar.bz2
gentoo-5abf39bdebe96fa45d301c52fcbc86ded2d50a50.zip
app-containers/grype: add 0.48.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers/grype')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.48.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index 7988e683c9d8..c184dcafe88d 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -2,3 +2,5 @@ DIST grype-0.44.0-deps.tar.xz 641743984 BLAKE2B f30557d75628f84dff70ca4272555c7c
DIST grype-0.44.0.tar.gz 1071804 BLAKE2B 2334ec9b9c04dfc03dbd280725a55bb6cdcd4569431eeb94abe799c75be08ff5164446cba7e97e3dc0ed8dcc10ba4bc8f70edecf9766cdc63e91b3dd420de391 SHA512 7573d03c2e0cbabb6ae3a91ebaa65848a7b43fc3624416f6c52a001acf6cfc839bce806e8e914c29bc2d0fc1aadd9b568ffc21d5a60bd9c05905e0185d7bdcd3
DIST grype-0.45.0-deps.tar.xz 644905072 BLAKE2B 5f1dd53106798b861ed90ed502406aa844fb99448fc8bf30dec3d32749db00c11106a16a93c2d92893cb2e8611b6dae7c63d9a5dfcc56b98fd373c3f8ddafc28 SHA512 31c343e898a880c91f7153e258e68d4c350484c9edcabb7b4a0df4d18a10b518b6878d04b5d96b8029855bf81f0b59fc052ee1cac3bcb27bdcfa334bdbe876ce
DIST grype-0.45.0.tar.gz 1074637 BLAKE2B 4cfa86a0ad695971241c40f19f982f54654642ff31f7220583af3b3aa0c1d6ca56f613e96b7343c4cb32b567efeb81c2145c19f009183b3d7f23ddeb1f01e02d SHA512 0a899c420d3d6ed9e669a0d02b0d79f0c63d50288b31c44cbbe61a883d46b93bf98be263cd7859d392ee40b82754c8cbe9b284dec593f79c5906988b01369209
+DIST grype-0.48.0-deps.tar.xz 648540700 BLAKE2B 4332364215da90be1978b4d7038b6ef3ee72c33f5e98c432999ee8335047bf0516c45aeb8854f7e9d6a33055194c45246da32f3bab98aaabf9c4c8346c3a014b SHA512 7034b5662700a440a29f0cdbb870c65fd6d5fca47abb58762da88f0e70918d2436e603baf53dab0340074ff586f1bd71350254f65be153f3d1d03a36d0fba28b
+DIST grype-0.48.0.tar.gz 1077714 BLAKE2B ec30c6421eb7ce9ef1d22a81db3149a076efcd32659471ff1f4ef00fe79176baf16ad6f1d682167c45349baff2bd49fda4207c84883ab5ac6e01b7e54bfb4af0 SHA512 9c7a27b10ce527ee0b131e60406ad2a8c6f28fbb138b475abd799a7b28f3709c987298bb6f8364f784a4fbe780d00ccd1061a0fb5066c63b5a1c42a5ea2b2d58
diff --git a/app-containers/grype/grype-0.48.0.ebuild b/app-containers/grype/grype-0.48.0.ebuild
new file mode 100644
index 000000000000..f65ef929b5f3
--- /dev/null
+++ b/app-containers/grype/grype-0.48.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=e9df59b4b1bd56c370500b5072eeace3ab51f8b3
+SYFT_VERSION=0.54.0
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}