summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-25 15:59:08 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-03-25 15:59:08 -0500
commit095a4de41a87acf532db725a0562bd55e00af66e (patch)
tree0b637052fedbbb32a6cd87791babf3e91a2b50c6 /app-containers
parentdev-ml/findlib: Stabilize 1.9.6 ppc64, #901661 (diff)
downloadgentoo-095a4de41a87acf532db725a0562bd55e00af66e.tar.gz
gentoo-095a4de41a87acf532db725a0562bd55e00af66e.tar.bz2
gentoo-095a4de41a87acf532db725a0562bd55e00af66e.zip
app-containers/grype: add 0.59.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.59.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index 6fe0cda24f1d..b90d79fb3721 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -2,3 +2,5 @@ DIST grype-0.48.0-deps.tar.xz 648540700 BLAKE2B 4332364215da90be1978b4d7038b6ef3
DIST grype-0.48.0.tar.gz 1077714 BLAKE2B ec30c6421eb7ce9ef1d22a81db3149a076efcd32659471ff1f4ef00fe79176baf16ad6f1d682167c45349baff2bd49fda4207c84883ab5ac6e01b7e54bfb4af0 SHA512 9c7a27b10ce527ee0b131e60406ad2a8c6f28fbb138b475abd799a7b28f3709c987298bb6f8364f784a4fbe780d00ccd1061a0fb5066c63b5a1c42a5ea2b2d58
DIST grype-0.51.0-deps.tar.xz 601816220 BLAKE2B 441982389af5e33cbe988571464cad0303b15971a5ed8b99c07b4d92404a6e636842e783b69c9f6f7de21c453edd9bfed5d78b60ebaa75abce55da638792205f SHA512 5e384ccd7ea6f777f4dbcdc8eff38402a965e87c68174e9ac4e33522b49b194e14a12104308df80ca6291dae934979750de5ccd8b38edc0fd6fb6be460705df0
DIST grype-0.51.0.tar.gz 1124375 BLAKE2B 6d2fb92edd2bc174d0879426f56812be7ede7e8c83cae49a0dee9781b0a771592f352b9a4fb96f87e8031592295c255e041bf30d0e5be5c24887c8436d505cf8 SHA512 4d1868a74523279734239836421c6a17595baa3179c80d18dba04cc5188e29eb5d97bc3102c931e9b1995a9afbc1da03d95d52bb8d74f5465c7415a1b16f947c
+DIST grype-0.59.1-deps.tar.xz 555292828 BLAKE2B ce132ecd42efd2c76bce1843b1da2ff763494a0206c8618c95ec03ae9d73a77378a68e503de9115c73efd6acbab4cc30bf222676c7888aafb08de8454351fb2b SHA512 aa627bfbf52c218786d009dee6e37bc09d70fd98ad10b8c07ec91db9d15380a1fbc35f380ee22fae8b6e7b090d1aabfebf58bc1ea6bca2bd179dcaa74b52a2c0
+DIST grype-0.59.1.tar.gz 1021093 BLAKE2B 0c5b0a8a14e297e123965d451daff082cbabb01f766ec355a37d54d7044b865430aa7cbec20d8002feac33f93e24565ebe6346a8559e8a25bf3df1dcc8ca217e SHA512 8f219ade9d7369f124dd8c035f3bef6ce5055e318d7ab1578f7f98a7fa6e842dad26fae8b2337884d4af3773b2c590b61485a490f98c66dfcbd82ef73d8b766b
diff --git a/app-containers/grype/grype-0.59.1.ebuild b/app-containers/grype/grype-0.59.1.ebuild
new file mode 100644
index 000000000000..3ce88f7f6d9d
--- /dev/null
+++ b/app-containers/grype/grype-0.59.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=29b646568901d1ef48a528cf35f67f3cead49c9f
+SYFT_VERSION=0.74.1
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}