summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-08 14:06:32 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-08 14:06:32 +0100
commit8b6bce543ecfe7a7f486e14b08affae08ff8998e (patch)
tree7d836c5d6d5e2f2f6c2ef7b2f845d33f3d8fa2cc /app-crypt/acme-sh
parentmedia-gfx/asymptote: remove old version (diff)
downloadgentoo-8b6bce543ecfe7a7f486e14b08affae08ff8998e.tar.gz
gentoo-8b6bce543ecfe7a7f486e14b08affae08ff8998e.tar.bz2
gentoo-8b6bce543ecfe7a7f486e14b08affae08ff8998e.zip
app-crypt/acme-sh: add 3.0.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-crypt/acme-sh')
-rw-r--r--app-crypt/acme-sh/Manifest1
-rw-r--r--app-crypt/acme-sh/acme-sh-3.0.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/acme-sh/Manifest b/app-crypt/acme-sh/Manifest
index 713a25283ece..3c9169a5a32e 100644
--- a/app-crypt/acme-sh/Manifest
+++ b/app-crypt/acme-sh/Manifest
@@ -1 +1,2 @@
DIST acme.sh-3.0.1.tar.gz 239311 BLAKE2B cbbaf6da068447c3400081889e249dc6f17f56df2038d75915eb990e417ecf5407c9c8272dfbd8403fac413357f30df552678ed27096de769ee5355f6343b6f4 SHA512 8bc5468fa70bf0a23f516b05e49f4c457cceb3ae0c12e963b538297912adce1f16fca200b116fc39a88ee0ba522e1757654ed231bebb6199ef7f5ad152511c71
+DIST acme.sh-3.0.2.tar.gz 248581 BLAKE2B 13d13a86a904909272c271d52d579065a7c84263ef2169b282b3bf270f33c7a8405aca640724120c08d1f495ea2a39035d46e1ec7f7eecfc093ce4dfa7c33b7d SHA512 6bd40951df02e3eaa1ed0efd8767acb5245e9c26c666ec7087db2cd0a38b65ea3c79ade98be954b4fbde0e89b6a988ac1c85ce2a6bd77b33574fb3fc0266ea03
diff --git a/app-crypt/acme-sh/acme-sh-3.0.2.ebuild b/app-crypt/acme-sh/acme-sh-3.0.2.ebuild
new file mode 100644
index 000000000000..7a7a567f6e0f
--- /dev/null
+++ b/app-crypt/acme-sh/acme-sh-3.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+inherit optfeature
+
+DESCRIPTION="A pure Unix shell script implementing ACME client protocol"
+HOMEPAGE="https://github.com/acmesh-official/acme.sh"
+SRC_URI="https://github.com/acmesh-official/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/openssl:0
+ net-misc/curl
+ net-misc/socat
+"
+
+src_install() {
+ newdoc deploy/README.md README-deploy.md
+ newdoc dnsapi/README.md README-dnsapi.md
+ rm {deploy,dnsapi}/README.md || die
+ einstalldocs
+
+ exeinto /usr/share/acme.sh
+ doexe acme.sh
+
+ insinto /usr/share/acme.sh
+ doins -r deploy dnsapi notify
+
+ keepdir /etc/acme-sh
+ doenvd "${FILESDIR}"/99acme-sh
+
+ insinto /etc/bash/bashrc.d
+ doins "${FILESDIR}"/acme.sh
+
+ dosym ../share/acme.sh/acme.sh usr/bin/acme.sh
+}
+
+pkg_postinst() {
+ optfeature_header "For webserver mode, install a supported web server:"
+ optfeature "using apache2 webserver mode" www-servers/apache
+ optfeature "using nginx webserver mode" www-servers/nginx
+}