summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-02 07:12:13 +0000
committerSam James <sam@gentoo.org>2021-01-02 07:12:13 +0000
commita0855564a0721d066a598a7d2e420a98a525e49d (patch)
tree24aeaf3b96407951b50c2825e1bbb336cb147c85 /app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild
parentprofiles/package.mask: drop obsolete =dev-libs/crypto++-8.3.0 mask (diff)
downloadgentoo-a0855564a0721d066a598a7d2e420a98a525e49d.tar.gz
gentoo-a0855564a0721d066a598a7d2e420a98a525e49d.tar.bz2
gentoo-a0855564a0721d066a598a7d2e420a98a525e49d.zip
app-crypt/codecrypt: revbump for dev-libs/crypto++ subslot dep
Bug: https://bugs.gentoo.org/762241 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild b/app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..8fa13a272f4b
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.7.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp:=
+ cryptopp? ( dev-libs/crypto++:= )
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ # workaround -- gentoo is missing crypto++ pkg-config file
+ sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ $(use_with cryptopp )
+}