summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-dicts/qvortaro
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-dicts/qvortaro')
-rw-r--r--app-dicts/qvortaro/Manifest1
-rw-r--r--app-dicts/qvortaro/files/qvortaro-0.4.1-gcc45.patch13
-rw-r--r--app-dicts/qvortaro/metadata.xml7
-rw-r--r--app-dicts/qvortaro/qvortaro-0.4.1.ebuild29
4 files changed, 50 insertions, 0 deletions
diff --git a/app-dicts/qvortaro/Manifest b/app-dicts/qvortaro/Manifest
new file mode 100644
index 000000000000..bdcbe71e6e8b
--- /dev/null
+++ b/app-dicts/qvortaro/Manifest
@@ -0,0 +1 @@
+DIST qvortaro-0.4.1.tar.gz 174664 SHA256 e576eb6bdc9bdedb67d89488a0d163a3d6eebc7b33a385708403e62c4ed46928 SHA512 a3ac90597d1e2f530f4fe1482945e266ca2db00ecdffa12a9aa9087c9730e52e0a89baeea685801a311962ab3fbcb57c1fc67d35be2612f93a812421da06579c WHIRLPOOL 949ab46eb1f2b9065ecf65acc16ace9564413b12fc50927938a1fe65149ebf53c77c385db37a0ea26b12dd3675885901c9434c832f44c3c2439dcbc920dfe269
diff --git a/app-dicts/qvortaro/files/qvortaro-0.4.1-gcc45.patch b/app-dicts/qvortaro/files/qvortaro-0.4.1-gcc45.patch
new file mode 100644
index 000000000000..431cdc4914bf
--- /dev/null
+++ b/app-dicts/qvortaro/files/qvortaro-0.4.1-gcc45.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/322213
+
+--- src/eolistbrowser.cpp
++++ src/eolistbrowser.cpp
+@@ -28,7 +28,7 @@
+ {
+ ui.setupUi(this);
+
+- rxEscape = QRegExp::QRegExp("('|_|%){1}");
++ rxEscape = QRegExp("('|_|%){1}");
+
+ m_model = new QSqlQueryModel(this);
+ ui.list->setModel(m_model);
diff --git a/app-dicts/qvortaro/metadata.xml b/app-dicts/qvortaro/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/app-dicts/qvortaro/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-dicts/qvortaro/qvortaro-0.4.1.ebuild b/app-dicts/qvortaro/qvortaro-0.4.1.ebuild
new file mode 100644
index 000000000000..c927848c2cca
--- /dev/null
+++ b/app-dicts/qvortaro/qvortaro-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qt4-r2
+
+DESCRIPTION="Esperanto Dictionary"
+HOMEPAGE="http://qvortaro.berlios.de/"
+SRC_URI="mirror://berlios/qvortaro/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+"
+
+PATCHES=( "${FILESDIR}/${P}-gcc45.patch" )
+
+src_install() {
+ dobin qvortaro || die
+ newicon src/img/icon_16.png ${PN}.png
+ make_desktop_entry ${PN} qVortaro
+ dodoc readme.txt
+}