summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-07-25 10:44:45 +0200
committerUlrich Müller <ulm@gentoo.org>2022-07-25 10:55:59 +0200
commit6b218a40fa9c6716e5d5d20de91b07fee20e5372 (patch)
treec3ad0894c03ae4f532cc0867c5ba938c390b7783 /app-doc/eclass-manpages
parentapp-doc/eclass-manpages: add 20220725 (diff)
downloadgentoo-6b218a40fa9c6716e5d5d20de91b07fee20e5372.tar.gz
gentoo-6b218a40fa9c6716e5d5d20de91b07fee20e5372.tar.bz2
gentoo-6b218a40fa9c6716e5d5d20de91b07fee20e5372.zip
app-doc/eclass-manpages: Drop conditionals for live ebuild
There is no code sharing between the functions in the non-live and live ebuilds, and it isn't expected that this will change in future. Therefore, the conditionals have little benefit but make the code harder to read. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-doc/eclass-manpages')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-99999999.ebuild38
1 files changed, 10 insertions, 28 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
index 4bbfc72582a4..13ddd2dacb8a 100644
--- a/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
+++ b/app-doc/eclass-manpages/eclass-manpages-99999999.ebuild
@@ -3,26 +3,12 @@
EAPI=8
-# Instructions to make a dist tarball:
-# git clone https://github.com/mgorny/eclass-to-manpage && cd eclass-to-manpage
-# make dist ECLASSDIR=~/g/eclass/
+inherit git-r3
DESCRIPTION="Collection of Gentoo eclass manpages"
HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
- https://github.com/gentoo/gentoo.git"
- inherit git-r3
-
- MY_ECLASSDIR="eclass"
-else
- SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
-
- # Keep the keywords stable. No need to change to ~arch.
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-
- MY_ECLASSDIR="."
-fi
+EGIT_REPO_URI="https://anongit.gentoo.org/git/repo/gentoo.git
+ https://github.com/gentoo/gentoo.git"
LICENSE="GPL-2"
SLOT="0"
@@ -31,21 +17,17 @@ BDEPEND="sys-apps/gawk
sys-apps/groff"
src_unpack() {
- if [[ ${PV} == *9999* ]] ; then
- git-r3_fetch
- git-r3_fetch "https://github.com/mgorny/eclass-to-manpage"
-
- git-r3_checkout '' '' '' eclass
- git-r3_checkout "https://github.com/mgorny/eclass-to-manpage"
- else
- default
- fi
+ git-r3_fetch
+ git-r3_fetch "https://github.com/mgorny/eclass-to-manpage.git"
+
+ git-r3_checkout "" "" "" eclass
+ git-r3_checkout "https://github.com/mgorny/eclass-to-manpage.git"
}
src_compile() {
- emake ECLASSDIR=${MY_ECLASSDIR}
+ emake ECLASSDIR=eclass
}
src_install() {
- emake install ECLASSDIR=${MY_ECLASSDIR} DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+ emake install ECLASSDIR=eclass DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
}