summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-02 19:30:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-02 19:51:08 +0200
commit4312fdb3fb49eb31bc36767ae796e432536bf648 (patch)
tree54279eb0e93b8834c957ab0d84bea40bf3fb371e /app-doc/python-docs
parentdev-lang/python: Bump to 3.11.6 (diff)
downloadgentoo-4312fdb3fb49eb31bc36767ae796e432536bf648.tar.gz
gentoo-4312fdb3fb49eb31bc36767ae796e432536bf648.tar.bz2
gentoo-4312fdb3fb49eb31bc36767ae796e432536bf648.zip
app-doc/python-docs: Bump to 3.11.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.11.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 26cc55c450b7..ff0e5e692404 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.13-docs-html.tar.bz2 7429989 BLAKE2B 7ddd11dbc4012cebf2f5980653b761ee35b986b75d96d582800f84e4c371aee4b82fcc2001c744e7f14991e766b0930a9ef4cb46869544e0aa403e513c4bd418 SHA512 be2cb6a2ece7849b1c259e9d86b7cf5e2a91c30a976b155c4055fc229d35a1762a90321a6227e890b6d5be51ab3377b9059b9662eed683933ec676fc2dc5f9a9
DIST python-3.11.5-docs-html.tar.bz2 7861520 BLAKE2B ed43fba98f8446b758c1d81ccd4af297232499b666045d6b9b4190d33871e0fbb4e6e166783d54e923b02694a49bdfd791664c7bcab1392ab86254c45d9fe81d SHA512 911a70145aa919687982b9fb34fc0cedafcf654cf3f1e6908a6077d27718aedabc923ea49648d453584f7a7171138e19c1a99f32cb8d41731e5d9c50dc30df2d
+DIST python-3.11.6-docs-html.tar.bz2 7881012 BLAKE2B b20cb04dc32d6eacc904aaf3505a919c6a17dce9105899632571574e734c42693ce5f469bb5f2194bcc16eb4458b6df382c5b4fd24b398f21660c6388b87702a SHA512 a0b118ea3d8f17e5c0a4abec353bc8fd04603db2da51375272e164f8c93be7e3a992eaac3d256a9d05c2db26f830e4b4add40cdb2e1108b936ff4d358cbbb40c
DIST python-3.8.18-docs-html.tar.bz2 6729312 BLAKE2B 431b8d5029d09fc2f54fdc998799298ccb6571a68c735320c95469a81e62bc7c2a9ec0ec11caa9886ad6a2d643b8d715e6866c398ec153d101b16efb85cda656 SHA512 80bdbec04355644f4b114e74da3334b4980d783a52ac8c999ede72f39b6137d94f1aaca248a386cfa02d778a10bdd7919ad82932f0aa000b16c102c8cee67e52
DIST python-3.9.18-docs-html.tar.bz2 7023072 BLAKE2B 92273a711cc8c2a35104f7c35bdca50ee0e9794c72aa14e9c4e613298dd6f2ecebbe977a35f1520a8585f1ea3112e8ea8e477c0e3503b025b6cec875fe40033e SHA512 d123266c72db81703c386dc0d436243a36996c39cde382939cebea31ff7a0c049470daa27efc34a3a0d55310bc6fe489ba01572ca961f67ba7a098038f2cb5af
diff --git a/app-doc/python-docs/python-docs-3.11.6.ebuild b/app-doc/python-docs/python-docs-3.11.6.ebuild
new file mode 100644
index 000000000000..2ab918028481
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.11.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}