summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBharath Saiguhan <bharathsaiguhan@protonmail.com>2022-09-10 18:14:03 +0530
committerSam James <sam@gentoo.org>2022-09-11 19:13:23 +0100
commit545106ff82c8c0795c08656235b0e1c235848d09 (patch)
tree2c6c2dabdbc20af9a90a1948a3b570d1a2f0d8ed /app-editors/neovim
parentdev-lang/zig-bin: add notes regarding standard library and patches (diff)
downloadgentoo-545106ff82c8c0795c08656235b0e1c235848d09.tar.gz
gentoo-545106ff82c8c0795c08656235b0e1c235848d09.tar.bz2
gentoo-545106ff82c8c0795c08656235b0e1c235848d09.zip
app-editors/neovim: fix live ebuild patch file
Upstream has changed its CMakeLists.txt file, replacing the deprecated variable CMAKE_COMPILER_IS_GNUCC, which causes the patch phase of the live ebuild to fail. This commit fixes this issue and with this in place, patching succeeds. Signed-off-by: Bharath Saiguhan <bharathsaiguhan@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/27198 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/neovim')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index cf3e05716625..571de0813ca6 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -26,7 +26,7 @@
- # Work around some old, broken detection by CMake for knowing when to use the
- # isystem flag. Apple's compilers have supported this for quite some time
- # now.
-- if(CMAKE_COMPILER_IS_GNUCC)
+- if(CMAKE_C_COMPILER_ID_MATCHES "GNU")
- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
- endif()
-endif()