summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-10 22:40:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-11 00:33:55 +0200
commitd1f53687c90c8e2ad66d0cbb11daa64b1706fde1 (patch)
tree37eeb000e4f3007b2b218299ed4ce2881e5b44e8 /app-editors/okteta
parentmedia-gfx/kphotoalbum: add 5.13.0 (diff)
downloadgentoo-d1f53687c90c8e2ad66d0cbb11daa64b1706fde1.tar.gz
gentoo-d1f53687c90c8e2ad66d0cbb11daa64b1706fde1.tar.bz2
gentoo-d1f53687c90c8e2ad66d0cbb11daa64b1706fde1.zip
app-editors/okteta: add 0.26.18
See also: https://mail.kde.org/pipermail/kde-announce-apps/2024-October/005829.html Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/okteta')
-rw-r--r--app-editors/okteta/Manifest1
-rw-r--r--app-editors/okteta/okteta-0.26.18.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-editors/okteta/Manifest b/app-editors/okteta/Manifest
index e62a8b9983df..14c488bb8989 100644
--- a/app-editors/okteta/Manifest
+++ b/app-editors/okteta/Manifest
@@ -1 +1,2 @@
DIST okteta-0.26.17.tar.xz 1090720 BLAKE2B f062e2fe2be54d4895fdc27e545885621e6e31932e23f8f098e88bb4b1dc01d08e2376621bfbed7e729e0b264a2a46ded8819ce0041e86e0f17e150ac875137f SHA512 0ef8c43802596e124dfeaff1edfc1f77d239fbbe6daaa70eda6f48e77ae3d09ea730da8757a9a52986efc822d8e9692587636fd9ecbf1ce7689362a48079d6b9
+DIST okteta-0.26.18.tar.xz 1099416 BLAKE2B 1cde103b33a8aedae9c3792c581c2ae65bbe6a1c63ba98e0332c59635c1156ab46ae596b7577a014e0b8ca65f28694d95cc20db573025dcde62eb5d03c451657 SHA512 7f6cc128642f07fb87faa733f8912e2acc033fd7f5be5743f7cb4d6e60db069713c93bd41a52966a8b97d6d2be716a5722c2d6da5a2b6f5f3a7d55c82d3198fd
diff --git a/app-editors/okteta/okteta-0.26.18.ebuild b/app-editors/okteta/okteta-0.26.18.ebuild
new file mode 100644
index 000000000000..b6d71d509277
--- /dev/null
+++ b/app-editors/okteta/okteta-0.26.18.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="true"
+KFMIN=5.115.0
+QTMIN=5.15.12
+inherit ecm kde.org
+
+DESCRIPTION="Hex editor by KDE"
+HOMEPAGE="https://apps.kde.org/okteta/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 handbook? ( FDL-1.2 )"
+SLOT="5"
+IUSE="crypt"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtscript-${QTMIN}:5[scripttools]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ crypt? ( >=app-crypt/qca-2.3.9:2[qt5(-)] )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.26.13-doctools-optional.patch" ) # downstream
+
+src_configure() {
+ local mycmakeargs=(
+ -DOMIT_EXAMPLES=ON
+ $(cmake_use_find_package crypt Qca-qt5)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ local myctestargs=( -j1 )
+
+ ecm_src_test
+}