summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/yudit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/yudit')
-rw-r--r--app-editors/yudit/Manifest2
-rw-r--r--app-editors/yudit/metadata.xml7
-rw-r--r--app-editors/yudit/yudit-2.9.2.ebuild34
-rw-r--r--app-editors/yudit/yudit-2.9.6.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/yudit/Manifest b/app-editors/yudit/Manifest
new file mode 100644
index 000000000000..3db07fd0c131
--- /dev/null
+++ b/app-editors/yudit/Manifest
@@ -0,0 +1,2 @@
+DIST yudit-2.9.2.tar.gz 2831966 SHA256 d9bb2fbf49dbc192b33a9095a819c6ee0b62bf46839333c286371786ab1acfc9 SHA512 39bbd6f1696a97922a5db83b25b52609660ea77c7651cfde1d7189789e7d9a6298f6dd91acf17ab9d1bef1fabbdeb7bb1f9ab95a14198913c84c30154efd9e07 WHIRLPOOL cc45b5cc6f7c2f683b76cf5bad81de78938c7ac0a7bebbe98a360e52f633dded01189047fd90f2eca632c8629a2090dfdb996fbe4ca8a0a35101364e52233aa3
+DIST yudit-2.9.6.tar.gz 2797142 SHA256 ded0b47742fce92aedb6403e8e758162abc73395f9c5a3268ceb2093fbfdf906 SHA512 a9a0b6f6c44451cf2fefc4fc0bb1bbd9ffccd17c4c622dc35b08113245b3bb9f3ca949f3e7b9d2aa919ebf3840295c5e63c0297576e74a5f2d1fb99cfc97c46b WHIRLPOOL b6a0a008ce67d6c2354ea74ee03dd6316cb86f091db5497dc329363c03dc805b8ac7191103f6372e8f4780604c309d8b77365d4600992d4ded09036c0c824bb0
diff --git a/app-editors/yudit/metadata.xml b/app-editors/yudit/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-editors/yudit/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-editors/yudit/yudit-2.9.2.ebuild b/app-editors/yudit/yudit-2.9.2.ebuild
new file mode 100644
index 000000000000..3445aa6533b9
--- /dev/null
+++ b/app-editors/yudit/yudit-2.9.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="http://www.yudit.org/"
+SRC_URI="http://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10"
+
+src_prepare() {
+ #Don't strip binaries, let portage do that.
+ sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
+}
+
+src_compile() {
+ #FIXME:
+ #-j1 because this app builds a tool called 'mytool' and we need to make
+ #sure that it is built before it needs to be used.
+ emake -j1
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc {BUGS,CHANGELOG,NEWS,TODO,XBUGS}.TXT
+}
diff --git a/app-editors/yudit/yudit-2.9.6.ebuild b/app-editors/yudit/yudit-2.9.6.ebuild
new file mode 100644
index 000000000000..4fa21b5d6360
--- /dev/null
+++ b/app-editors/yudit/yudit-2.9.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="http://www.yudit.org/"
+SRC_URI="http://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.10"
+
+src_prepare() {
+ #Don't strip binaries, let portage do that.
+ sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc {BUGS,CHANGELOG,NEWS,TODO,XBUGS}.TXT
+}