summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-02-15 20:29:13 +0100
committerUlrich Müller <ulm@gentoo.org>2020-02-15 20:30:57 +0100
commit0068b6c6ebb346e144381af1c87bce606e664328 (patch)
tree5ad9b1d1347a95805f21f0f29e6e17b59c3b9f2c /app-editors
parentapp-portage/pfl: stable 3.0.1-r3 for sparc, bug #706146 (diff)
downloadgentoo-0068b6c6ebb346e144381af1c87bce606e664328.tar.gz
gentoo-0068b6c6ebb346e144381af1c87bce606e664328.tar.bz2
gentoo-0068b6c6ebb346e144381af1c87bce606e664328.zip
app-editors/mg: Version bump to 20200215.
Closes: https://bugs.gentoo.org/707450 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20200215.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index a45c051fd34a..146459d9c677 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,2 +1,3 @@
DIST mg-20171014.tar.gz 141045 BLAKE2B a5b3bda6ff3b6416093069b471762687c2279737aa05b297ccd3077aff195cf52831566768613a81dcc977a27ac5ffd6e8a1874aa1010b6d90f4c678b6825cee SHA512 d55818308421aa523fb30b6e4725bb122f37637a822fabafeba9f9da3b97fd7f6af6431fce3015c969d0e656a48e89ed49b790deefc69fbdbb7e257f8a1aeb56
DIST mg-20180408.tar.gz 141988 BLAKE2B db7da46fb0160acf8695f05234ed0c8e9a45e4239dc3abd433ddfb8b66e2b1aa550ffc4b409486a8990881d791ed73269a8ab78f6846cd4f0bee67761c11d281 SHA512 25fceb18fcbe63010e7a2e107aa5c30356938be2e04ff48869a12b5018dbb83bcf4dc70b03674713516616037247952a51454a28ca418cdc7b020d1f415f8701
+DIST mg-20200215.tar.gz 152254 BLAKE2B 89e47aaa94fd95b9409a53b09c9017e26d3f1cc73ce616e1c29ed22fbaed42cb78e7c9fbcd2424d98f86725fb00cee5160be4fe40abc97a927201557b684f800 SHA512 c6cda5544210bc3d3fa3cbb8494e60949e10ed3716d96b76d0c9e7f5671c7a85f6e7e7a860cfd05466f1bf52112053c722441ff338210c0ada89f10515ac170a
diff --git a/app-editors/mg/mg-20200215.ebuild b/app-editors/mg/mg-20200215.ebuild
new file mode 100644
index 000000000000..0df3d41ffca7
--- /dev/null
+++ b/app-editors/mg/mg-20200215.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}