summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-11-21 20:40:26 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-11-21 20:46:15 +0000
commit5083ea117cd66860f8e2db7b8fd600ee326af928 (patch)
tree5d374b12cd5985ab2e3c34857a2d5aa7066c3b6c /app-editors
parentdev-ml/opam-0install-cudf: new package, add 0.5.0 (diff)
downloadgentoo-5083ea117cd66860f8e2db7b8fd600ee326af928.tar.gz
gentoo-5083ea117cd66860f8e2db7b8fd600ee326af928.tar.bz2
gentoo-5083ea117cd66860f8e2db7b8fd600ee326af928.zip
app-editors/vscode: add 1.95.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.95.3.ebuild131
2 files changed, 134 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 39f06af0bf3b..1b1f433bff9d 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -7,3 +7,6 @@ DIST vscode-1.95.1-arm64.tar.gz 144398553 BLAKE2B 54d9bcba210df773a10361c79329d2
DIST vscode-1.95.2-amd64.tar.gz 148406981 BLAKE2B cf76d73f3ea9d993cb25a2c69ddca39ea4b17754ed3eba1e778169f5471fcc57b4ebf79357f80f47aa8d58e0913587e9558f5fa95cf031ae1eddf7f702eac200 SHA512 f203f8f7e40d665d6eb77069473f10842e896776dfe3c0c8c502fa46798f524c8125d50020576e33ea3890b592d5ddf36d488039fbc75d0bd6d638304a8059ad
DIST vscode-1.95.2-arm.tar.gz 132480370 BLAKE2B ef4f2c352be078a0941aba8fb84efb6795cd95ef9c2d14620fc1dfd4e7c97006618e100ab0434c380007b30b540cc58e3a65dc830e5faf8588fc0bdbc78f2610 SHA512 e1a3990bfbdbfac3b1ec7041e1e85307d39a1beb3bc42c79a23a9f07aa596fd41c8528b086702535fa862adadfe97397d4bd3c90fff3b3bcb1cddb1b78a61e8e
DIST vscode-1.95.2-arm64.tar.gz 144419300 BLAKE2B 2f0720344a72b529e1dff6d413e9e715d47a6436610564911d584aad218998547f84672ac934effdcc211957c7d9c17acd8464d4c159a6b3451149d944127691 SHA512 c8680de5489b61542ca6d3d9a62b6a1c273ee4a5fcfbe7bb78e9da9fcee7668a908c72ec2081e1caf5dae539a884f3d9576ef91373c38a9e27d1c5b7c1b65d7e
+DIST vscode-1.95.3-amd64.tar.gz 148378619 BLAKE2B 2bb94b67e48583a3484e2c3af637f0a05b88340e862bdb3f318aa15cf22f78ac165f0769b3a56d7565763f0ce6aa31e793f54981b5b45029384f39c857fbbed9 SHA512 c20ff3e28c81070bc3919ad879e14ba898f14b2fa47bba5574144665f01c811bf3d93be72afbe314cba382faaae187f93c5c7f9bf60c488095fbb327115fba62
+DIST vscode-1.95.3-arm.tar.gz 132455720 BLAKE2B 62fcf8f1708bca3f92e2e710b990b8a714f5386edda293e720fcbf1fba972664d9db259acedf045c79f091edb6e3fe29d6fd08ebeebb72c01ac0498737000216 SHA512 bc3dc9611eaaab8c65574417c4f98603a341928a45b52c182b3d0dcaa1cc74ef815a61bd47ace6de164de688e92bd9f17cb6c2b032f8af00010a360c223596f5
+DIST vscode-1.95.3-arm64.tar.gz 144398988 BLAKE2B 2bae1b98e3bcb5c3bab388035b5b0b1137b7e7ff77eda6f6809eca424f1956845218fb2c5366d7ec24e71f7b1684935e12329f481168c977a3c0553b549e6f02 SHA512 bc3386abd90231c11d9a10b6bba62b627dadd4701fb06c7e20eb4e2b80284416c36532b023767daecb58ab3a70107151ca570b1d345d3a1415adaa7510a3bd0a
diff --git a/app-editors/vscode/vscode-1.95.3.ebuild b/app-editors/vscode/vscode-1.95.3.ebuild
new file mode 100644
index 000000000000..7757235fed73
--- /dev/null
+++ b/app-editors/vscode/vscode-1.95.3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}