summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-06 12:19:07 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-06 14:07:24 +0100
commite675aff31a8dc3113e19999dacd9150481b0a6e8 (patch)
tree0e38101b273a66dc6bb74bc5ee58fac8ffea516f /app-emacs/ebib
parentapp-emacs/ebib: drop old 2.39.4 (diff)
downloadgentoo-e675aff31a8dc3113e19999dacd9150481b0a6e8.tar.gz
gentoo-e675aff31a8dc3113e19999dacd9150481b0a6e8.tar.bz2
gentoo-e675aff31a8dc3113e19999dacd9150481b0a6e8.zip
app-emacs/ebib: bump to 2.40.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ebib')
-rw-r--r--app-emacs/ebib/Manifest1
-rw-r--r--app-emacs/ebib/ebib-2.40.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/ebib/Manifest b/app-emacs/ebib/Manifest
index 72248ebf3eba..3ff263a8f0dd 100644
--- a/app-emacs/ebib/Manifest
+++ b/app-emacs/ebib/Manifest
@@ -1 +1,2 @@
DIST ebib-2.40.3.tar.gz 1049725 BLAKE2B 651716ed5465a4ef93b149ab84018d7daf3ffa1df404b95625a9c3666a1dbbe3d879f180dae92aa619e70121757c4a3b7f566bfc8aed1542b2828de25775b6ff SHA512 4231f5732990828aa19d9d723fb9b74bf761e8034de24fce4748b95a4d969d5a3bbbdc443b4f1a4a88b945b01ded958ae467da4222b546121513a26759419bd6
+DIST ebib-2.40.4.tar.gz 1050093 BLAKE2B f7ca4deb262017aab9044702c4e0bcfadc26ffec1497d43aa96789f3b10304c040195302621646cbe7234f6b0bf12f30ec779173056bf1e6594b05a1a8b4025c SHA512 c856abe3653f17f3417d3021300a0d131b5119393185ce9e5082c599df14e7d51bbf8405653e28aed790a73b56533a1d07d18fc2c7a073c5664e40926ddfa957
diff --git a/app-emacs/ebib/ebib-2.40.4.ebuild b/app-emacs/ebib/ebib-2.40.4.ebuild
new file mode 100644
index 000000000000..688763487ce1
--- /dev/null
+++ b/app-emacs/ebib/ebib-2.40.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="BibTeX database manager for Emacs"
+HOMEPAGE="https://joostkremers.github.io/ebib/
+ https://github.com/joostkremers/ebib/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.4
+ app-emacs/parsebib
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/with-simulated-input
+ )
+"
+
+DOCS=( README.md docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}