summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-01 19:32:35 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-01 20:17:12 +0100
commitb9e7941ed9559b2ce36c22770ab59325e8e977ad (patch)
tree93911e353c34f97cb9d3030cc3344e38b1876a83 /app-emacs/ef-themes
parentapp-emacs/cider: bump to 1.10.0 (diff)
downloadgentoo-b9e7941ed9559b2ce36c22770ab59325e8e977ad.tar.gz
gentoo-b9e7941ed9559b2ce36c22770ab59325e8e977ad.tar.bz2
gentoo-b9e7941ed9559b2ce36c22770ab59325e8e977ad.zip
app-emacs/ef-themes: bump to 1.4.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ef-themes')
-rw-r--r--app-emacs/ef-themes/Manifest1
-rw-r--r--app-emacs/ef-themes/ef-themes-1.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/Manifest b/app-emacs/ef-themes/Manifest
index 2e6bc7d65c4a..fda058ba0b88 100644
--- a/app-emacs/ef-themes/Manifest
+++ b/app-emacs/ef-themes/Manifest
@@ -1 +1,2 @@
DIST ef-themes-1.3.0.tar.gz 159848 BLAKE2B 141b5d1c809ef285f8bbfa6b91c60a9e6c03d5677baccf451091b9d2141a5d49f3c4a7e3f69ffdb8ebe99253ebd8cf1756f15723dae07c4a7db2b165bc38012a SHA512 85a7310f710a4e91c72d9c47fb596eeca181bf282e4cfb3d16c9e714bace4f87cb5d7d8c76d06e36cde170956d2f3dc0bfe0cde5b5332656292cc511f05e9583
+DIST ef-themes-1.4.0.tar.gz 163456 BLAKE2B b3939d467ebf8c57c3975b5bd449bd419fa334febc2d792323b2b14c967e98a34537a766b350c668ff4e893eddd23a55104f7a7af4f437a21bf8e0006dc9fd17 SHA512 ddbad5f6829911cc8806b865ae0f7ef8741224a37b1f8c82bdc66ed0cc8475d1b76707b57bbf34a98bb71d3c9e8ea25d065a79efc1a5803a901f8e08968c83f9
diff --git a/app-emacs/ef-themes/ef-themes-1.4.0.ebuild b/app-emacs/ef-themes/ef-themes-1.4.0.ebuild
new file mode 100644
index 000000000000..e12280ff911b
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-1.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}