summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-07 13:24:02 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-07 13:31:36 +0200
commitff73c5c6d8f2753dfc725927feb28c856b0173bb (patch)
treea250096a7891c347a24fb1cefec00d65767690ef /app-emacs/eldev
parentapp-emacs/geiser: bump to 0.29.1 (diff)
downloadgentoo-ff73c5c6d8f2753dfc725927feb28c856b0173bb.tar.gz
gentoo-ff73c5c6d8f2753dfc725927feb28c856b0173bb.tar.bz2
gentoo-ff73c5c6d8f2753dfc725927feb28c856b0173bb.zip
app-emacs/eldev: bump to 1.5.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/eldev')
-rw-r--r--app-emacs/eldev/Manifest1
-rw-r--r--app-emacs/eldev/eldev-1.5.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/eldev/Manifest b/app-emacs/eldev/Manifest
index 943ff84875b7..9fcd1eaf2288 100644
--- a/app-emacs/eldev/Manifest
+++ b/app-emacs/eldev/Manifest
@@ -1,3 +1,4 @@
DIST eldev-1.4.1.tar.gz 268814 BLAKE2B d31ef7842888f523dab25d279064ceda2f427f70f3353d015485bc78346f368e2a56f1a5dfc0243efae36752576be32b869726e391b040eda9c3ea4418002d67 SHA512 485ccbdbcb40c3e2a19de5bad7b35bc439a4fe7c228c28ca0c75ca8292ff6216bbf78bb2d26678b94b9fcc5526aea12e1e9c6aa0368e343a08c9081ef1058e81
DIST eldev-1.5.1.tar.gz 277342 BLAKE2B 9efc21e393703aa6649bf95ce0ab774f0306e04371001ab8de9202a9c0c975c9c8ba695dddecfb2be1717b49862aaea9a4ea714f38ccd05545597a93ddf2d61b SHA512 a06f8ecd9b5e1536f03fc6b23b721febb11841fe63b610ae410fe1a317f9e0c28c5cba590104d899e3987acb17bf354bdd17a0447aa83fab99871717574e7598
+DIST eldev-1.5.2.tar.gz 278912 BLAKE2B 6f4aa63817f09bd5fc744a08b7204227c607e1c1cf586d31d0f1835bdc720ab41a272c9dbcd309a8512ef5ddec31db50f6d31e4d52446b66aa3b5abd0e7f6c36 SHA512 86f91c7dde1a1f1012268f6b32d86855d6996ab70c828c70dd188d01609dacbba8aa68dfd86a4995a1ee944aca08d08f844696bd70f996346279dd808ab446b2
DIST eldev-1.5.tar.gz 276909 BLAKE2B 963940d203c0864d091c50703d18805b48e3bcc4d4fec07262421c453ad346a3963d711b2a96f10e46c2329ba75f6a92093ec2845726e83958e6973a8d579b0a SHA512 fcb277175254de51b37caab04ba74422925b22d3bc98e9e84a2f563f3251fa2bfabb573c98800a05245713d256fbdb59d1091d94a037ddb3a7dda4879f451e88
diff --git a/app-emacs/eldev/eldev-1.5.2.ebuild b/app-emacs/eldev/eldev-1.5.2.ebuild
new file mode 100644
index 000000000000..413e8c727a11
--- /dev/null
+++ b/app-emacs/eldev/eldev-1.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs Lisp Development Tool"
+HOMEPAGE="https://github.com/doublep/eldev/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/doublep/${PN}.git"
+else
+ SRC_URI="https://github.com/doublep/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.adoc )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ELDEV_LOCAL="${S}" ./bin/${PN} test
+}
+
+src_install() {
+ elisp_src_install
+ dobin bin/${PN}
+
+ # NOTICE: If ELDEV_LOCAL is defined Eldev will use it
+ # to load up it's components,
+ # if it is not it will bootstrap itself from network
+ # always check if it uses installed Emacs Lisp files.
+ # Also, do not forget to run `env-update` & reopen your shell.
+ # https://github.com/doublep/eldev#influential-environment-variables
+ echo "ELDEV_LOCAL=${SITELISP}/${PN}" >> "${T}"/99${PN} || die
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ ewarn "Remember to run \`env-update && source /etc/profile\` if you plan"
+ ewarn "to use Eldev in a shell before logging out (or restarting"
+ ewarn "your login manager)."
+}