summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-10 19:35:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-10 20:16:33 +0100
commit880d64853c2e005d371bb70c5cfc51844c9d8525 (patch)
tree058083c200af121616aa0fe95e45134fba8c7b83 /app-emacs/embark
parentsys-apps/systemd: drop 255_rc3, 255_rc4 (diff)
downloadgentoo-880d64853c2e005d371bb70c5cfc51844c9d8525.tar.gz
gentoo-880d64853c2e005d371bb70c5cfc51844c9d8525.tar.bz2
gentoo-880d64853c2e005d371bb70c5cfc51844c9d8525.zip
app-emacs/embark: bump to 1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/embark')
-rw-r--r--app-emacs/embark/Manifest1
-rw-r--r--app-emacs/embark/embark-1.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emacs/embark/Manifest b/app-emacs/embark/Manifest
index 18d148f2a2ae..a606219ba46f 100644
--- a/app-emacs/embark/Manifest
+++ b/app-emacs/embark/Manifest
@@ -1 +1,2 @@
DIST embark-0.23.tar.gz 110865 BLAKE2B 8e4c3e46b58d052b17b3fa9a41083e2e2efc9173897e0da17f5da80ebe2445ea2a9f45879b3ce60aacac6ad195b29d228a6bf304c5434c9432d6db627ca7f9c0 SHA512 9541bce783d9b11a8d6102d6d68a48239e8408eebd4afa3de04221436fc97ff966445dee0ac7ec126cdd10b2c523324505b78464261673205c91da0d2075ac82
+DIST embark-1.0.tar.gz 112818 BLAKE2B 111203ec462b06f11dae9760a64d27e197faa13cefe1eb4debd2e7222380aab0ccad19587ee275f343bb0e2a716379e67209e27dcaa0aaaa7a98f97f660fb6f5 SHA512 ca42c6bd428807aefee6e7bb817651577401be8adacbd64146e97bd07ddd8df325dfeafeaa824fd3f4cd289da1a9b4868f44feacb66585f2533b64fa4d594d22
diff --git a/app-emacs/embark/embark-1.0.ebuild b/app-emacs/embark/embark-1.0.ebuild
new file mode 100644
index 000000000000..25a980dc33a9
--- /dev/null
+++ b/app-emacs/embark/embark-1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}