summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:55:17 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:34 +0200
commit52505a8d6019ac2f5d5698169fc171e2d36c996a (patch)
tree8a1e1d4dafa9e0139c40170e44794b2107ab6e79 /app-emacs/epc/epc-0.1.1.ebuild
parentapp-emacs/raku-mode: minor tweaks (diff)
downloadgentoo-52505a8d6019ac2f5d5698169fc171e2d36c996a.tar.gz
gentoo-52505a8d6019ac2f5d5698169fc171e2d36c996a.tar.bz2
gentoo-52505a8d6019ac2f5d5698169fc171e2d36c996a.zip
app-emacs/epc: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/epc/epc-0.1.1.ebuild')
-rw-r--r--app-emacs/epc/epc-0.1.1.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/app-emacs/epc/epc-0.1.1.ebuild b/app-emacs/epc/epc-0.1.1.ebuild
index 631dd47f8e71..1709c8e7e76c 100644
--- a/app-emacs/epc/epc-0.1.1.ebuild
+++ b/app-emacs/epc/epc-0.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,24 +7,31 @@ inherit elisp
DESCRIPTION="RPC stack for Emacs Lisp"
HOMEPAGE="https://github.com/kiwanami/emacs-epc/"
-SRC_URI="https://github.com/kiwanami/emacs-epc/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}"/emacs-${P}
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/kiwanami/emacs-epc.git"
+else
+ SRC_URI="https://github.com/kiwanami/emacs-epc/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/emacs-${P}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
RDEPEND="
app-emacs/ctable
app-emacs/deferred
"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+"
DOCS=( readme.md demo img )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ${EMACS} ${EMACSFLAGS} -L . -l epc.el -l epcs.el -l test-epc.el \
- -f ert-run-tests-batch-and-exit || die "tests failed"
-}
+elisp-enable-tests ert "${S}" -l epc.el -l epcs.el -l test-epc.el