summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-08-05 19:00:43 +0200
committerUlrich Müller <ulm@gentoo.org>2024-08-05 19:02:09 +0200
commit53573e7f647a5cefabd39b9b6908590547d2d35d (patch)
tree5f9a1f85518f7ed4638bf6b18ca670bef861c7ba /app-emacs
parentapp-emacs/distel: app-emacs/erlang-mode split (diff)
downloadgentoo-53573e7f647a5cefabd39b9b6908590547d2d35d.tar.gz
gentoo-53573e7f647a5cefabd39b9b6908590547d2d35d.tar.bz2
gentoo-53573e7f647a5cefabd39b9b6908590547d2d35d.zip
app-emacs/tty-format: new package, add 12
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/tty-format/Manifest1
-rw-r--r--app-emacs/tty-format/files/50tty-format-gentoo.el20
-rw-r--r--app-emacs/tty-format/metadata.xml9
-rw-r--r--app-emacs/tty-format/tty-format-12.ebuild18
4 files changed, 48 insertions, 0 deletions
diff --git a/app-emacs/tty-format/Manifest b/app-emacs/tty-format/Manifest
new file mode 100644
index 000000000000..518634aefadc
--- /dev/null
+++ b/app-emacs/tty-format/Manifest
@@ -0,0 +1 @@
+DIST tty-format-12.el.xz 6512 BLAKE2B 1a8fa04936cb12af062f60037b61a4204839a678d5ea566d08c4cfa9c48b24c8e32af8232f237bebf41ad1f64ba4fadf91d2b4e1f66cf1bfb27d00c78d25604e SHA512 5fd3285a7bb9c722a05d1621ac0958a366cc728165b594e17291de44e840874d50b983d1b774d7736e306fab3ac61095c97999abc821a20ab89fa088f461982f
diff --git a/app-emacs/tty-format/files/50tty-format-gentoo.el b/app-emacs/tty-format/files/50tty-format-gentoo.el
new file mode 100644
index 000000000000..9da580336ce5
--- /dev/null
+++ b/app-emacs/tty-format/files/50tty-format-gentoo.el
@@ -0,0 +1,20 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ansi-format-encode "tty-format")
+(autoload 'ansi-format-decode "tty-format")
+(autoload 'backspace-overstrike-encode "tty-format")
+(autoload 'backspace-overstrike-decode "tty-format")
+(autoload 'tty-format-guess "tty-format")
+
+(add-to-list 'format-alist
+ '(ansi-colors
+ "ANSI SGR escape sequence colours and fonts."
+ nil
+ ansi-format-decode ansi-format-encode t nil))
+
+(add-to-list 'format-alist
+ '(backspace-overstrike
+ "Backspace overstriking for bold and underline."
+ nil
+ backspace-overstrike-decode backspace-overstrike-encode t nil))
+
+(custom-add-option 'find-file-hook 'tty-format-guess)
diff --git a/app-emacs/tty-format/metadata.xml b/app-emacs/tty-format/metadata.xml
new file mode 100644
index 000000000000..986088003fe1
--- /dev/null
+++ b/app-emacs/tty-format/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+</pkgmetadata>
diff --git a/app-emacs/tty-format/tty-format-12.ebuild b/app-emacs/tty-format/tty-format-12.ebuild
new file mode 100644
index 000000000000..7b3ba8322ff0
--- /dev/null
+++ b/app-emacs/tty-format/tty-format-12.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Text file backspacing and ANSI SGR as faces"
+HOMEPAGE="https://user42.tuxfamily.org/tty-format/index.html
+ https://www.emacswiki.org/emacs/TtyFormat"
+# taken from https://download.tuxfamily.org/user42/tty-format.el"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"