summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-08 17:49:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-08 20:34:40 +0100
commita003308ae816f916a30983af41e54b7b1e3bf1f8 (patch)
tree8ed64687b0803eeabfebebb540786b2e76e49f21 /app-emacs
parentapp-emacs/matlab: bump to 6.1_p20241107 (diff)
downloadgentoo-a003308ae816f916a30983af41e54b7b1e3bf1f8.tar.gz
gentoo-a003308ae816f916a30983af41e54b7b1e3bf1f8.tar.bz2
gentoo-a003308ae816f916a30983af41e54b7b1e3bf1f8.zip
app-emacs/matlab: sync live 9999 version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/matlab/matlab-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/matlab/matlab-9999.ebuild b/app-emacs/matlab/matlab-9999.ebuild
new file mode 100644
index 000000000000..25d44d6bbb42
--- /dev/null
+++ b/app-emacs/matlab/matlab-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major modes for MATLAB .m and .tlc files"
+HOMEPAGE="https://github.com/mathworks/Emacs-MATLAB-Mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/mathworks/Emacs-MATLAB-Mode"
+else
+ [[ "${PV}" == *p20241107 ]] && COMMIT="f13f511670a52cfa23c4f065a231a3e691763633"
+
+ SRC_URI="https://github.com/mathworks/Emacs-MATLAB-Mode/archive/${COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/Emacs-MATLAB-Mode-${COMMIT}"
+
+ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS="README.org ChangeLog*"
+SITEFILE="50${PN}-gentoo-3.3.6.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file matlab-load.el
+}