summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-23 11:34:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-23 12:00:07 +0200
commite660a225aa0561d3a37ddd5b0b094462efc78e5d (patch)
tree185f65534c8398f3a7e787254165a91586f6b7c9 /app-emacs
parentapp-emacs/company-mode: bump to 1.0.2 (diff)
downloadgentoo-e660a225aa0561d3a37ddd5b0b094462efc78e5d.tar.gz
gentoo-e660a225aa0561d3a37ddd5b0b094462efc78e5d.tar.bz2
gentoo-e660a225aa0561d3a37ddd5b0b094462efc78e5d.zip
app-emacs/pandoc-mode: bump to 2.33
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/pandoc-mode/Manifest1
-rw-r--r--app-emacs/pandoc-mode/pandoc-mode-2.33.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/pandoc-mode/Manifest b/app-emacs/pandoc-mode/Manifest
index e3e76e674447..d5ac95ee3120 100644
--- a/app-emacs/pandoc-mode/Manifest
+++ b/app-emacs/pandoc-mode/Manifest
@@ -1 +1,2 @@
DIST pandoc-mode-2.32.tar.gz 97596 BLAKE2B 2a1c8a6080fbba1cf278d78f9dbe4e6824daed52ad6422378d6b5c00fd4ec9466391474fdbaad5f1cd96d89080c24968b33c0911cb5f834ddd64dc1339b78c01 SHA512 6717bf238a9f71acce8135d5fa0542c23f2b48d78415f92dda2ef58aa0355ca0fe900e1015d0da674abf7780ed614bd7d4414519bf6d0d7f5aee7e3b7a7f447f
+DIST pandoc-mode-2.33.tar.gz 97645 BLAKE2B d6bd6fa713f5b8d50bdaa8df880099a4fe670353ba98ac7d63d0fc6b5d7b4398a585a43c34d04e94fc794de666a45bff8b11a8a850d581553a64b5b2d5db5178 SHA512 a7d6ed18bd5cad3a70f0b15aedf4d70de723318ec082d60ad543b438d9fca19f04c91d5829fa431578089e03b00f365b9c939ea6f8c09367ae510ddd3fa8fc67
diff --git a/app-emacs/pandoc-mode/pandoc-mode-2.33.ebuild b/app-emacs/pandoc-mode/pandoc-mode-2.33.ebuild
new file mode 100644
index 000000000000..893a94b2f955
--- /dev/null
+++ b/app-emacs/pandoc-mode/pandoc-mode-2.33.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs minor mode for interacting with Pandoc"
+HOMEPAGE="https://joostkremers.github.io/pandoc-mode/
+ https://github.com/joostkremers/pandoc-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ app-emacs/dash
+ app-emacs/hydra
+"
+RDEPEND="
+ ${BDEPEND}
+ virtual/pandoc
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ doinfo "${PN}.info"
+}