summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-16 15:47:33 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-16 16:08:00 -0700
commit7eb7b617b0da973e1a57c47142acf66fb1b4c51e (patch)
treedabdca12c560a30bb07a1ec0585a41c0ca3cd9c8 /app-emulation/containers-storage
parentdev-python/sphinxcontrib-asyncio: keyword ~arm (diff)
downloadgentoo-7eb7b617b0da973e1a57c47142acf66fb1b4c51e.tar.gz
gentoo-7eb7b617b0da973e1a57c47142acf66fb1b4c51e.tar.bz2
gentoo-7eb7b617b0da973e1a57c47142acf66fb1b4c51e.zip
app-emulation/containers-storage: filter GOCACHE vars (bug 678856)
Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/678856 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/containers-storage')
-rw-r--r--app-emulation/containers-storage/containers-storage-0_pre20180730.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emulation/containers-storage/containers-storage-0_pre20180730.ebuild b/app-emulation/containers-storage/containers-storage-0_pre20180730.ebuild
index cd2ef64ffa54..d5caa6e3a626 100644
--- a/app-emulation/containers-storage/containers-storage-0_pre20180730.ebuild
+++ b/app-emulation/containers-storage/containers-storage-0_pre20180730.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -86,13 +86,14 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #678856
mkdir -p "${S}/src/github.com/pquerna" || die
ln -s "${S}/src/${EGO_PN}/vendor/github.com/pquerna/ffjson" "${WORKDIR}/${P}/src/github.com/pquerna/ffjson" || die
mkdir -p "${S}/bin" || die
cd "${S}/bin" || die
- GOPATH="${S}" GOBIN="${S}/bin" GOCACHE=off \
+ GOPATH="${S}" GOBIN="${S}/bin" \
go build -v -work -x ${EGO_BUILD_FLAGS} "${S}/src/github.com/pquerna/ffjson/ffjson.go" || die
- GOPATH="${S}" GOBIN="${S}/bin" PATH="${S}/bin:${PATH}" GOCACHE=off \
+ GOPATH="${S}" GOBIN="${S}/bin" PATH="${S}/bin:${PATH}" \
emake -C "${S}/src/${EGO_PN}" containers-storage docs
}