summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-15 16:23:01 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-18 13:44:41 +0000
commit185d0bcd193162f50dcf501eb504e4e138c8eb54 (patch)
tree309d58c38fa0bcd4d19450d7f58ee897add91d15 /app-emulation/libspectrum/libspectrum-1.5.0.ebuild
parentnet-proxy/haproxy: Version bumps to 2.1.12 and 2.2.11 (diff)
downloadgentoo-185d0bcd193162f50dcf501eb504e4e138c8eb54.tar.gz
gentoo-185d0bcd193162f50dcf501eb504e4e138c8eb54.tar.bz2
gentoo-185d0bcd193162f50dcf501eb504e4e138c8eb54.zip
app-emulation/libspectrum: bump to 1.5.0 and EAPI-7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/libspectrum/libspectrum-1.5.0.ebuild')
-rw-r--r--app-emulation/libspectrum/libspectrum-1.5.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/libspectrum-1.5.0.ebuild b/app-emulation/libspectrum/libspectrum-1.5.0.ebuild
new file mode 100644
index 000000000000..aec492d2edec
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-1.5.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audiofile bzip2 gcrypt zlib"
+
+RDEPEND="dev-libs/glib:2
+ audiofile? ( >=media-libs/audiofile-0.3.6 )
+ bzip2? ( >=app-arch/bzip2-1.0 )
+ gcrypt? ( dev-libs/libgcrypt:0 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with audiofile libaudiofile)
+ $(use_with bzip2)
+ $(use_with gcrypt libgcrypt)
+ $(use_with zlib)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # check only builds test executable but doesn't run it
+ emake check
+ ./test/test || die
+}
+
+src_install() {
+ default
+ dodoc doc/*.txt *.txt
+}