summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2017-09-04 19:38:24 -0400
committerAmy Liffey <amynka@gentoo.org>2017-09-21 14:40:55 +0200
commitebe9b5f89f27ea34d8efea91c9c16718cd088891 (patch)
tree86780d63d15457ef24bdf1b9afd747e10fc62355 /app-emulation/lxd/files
parentsci-geosciences/gpsd: Version bump. Fixes build with gcc-6, bug 595382. (diff)
downloadgentoo-ebe9b5f89f27ea34d8efea91c9c16718cd088891.tar.gz
gentoo-ebe9b5f89f27ea34d8efea91c9c16718cd088891.tar.bz2
gentoo-ebe9b5f89f27ea34d8efea91c9c16718cd088891.zip
app-emulation/lxd: Bump to v2.17
Other than copying, 2 changes were made: 1. `EGO_VENDOR` update 2. Removal of `golang-build_src_install` The second change was necessary because the "client.go" file at the root of the project was removed. Also, I was already planning on removing it, after having consulted with WilliamH on IRC, because this step installed many, many useless files in /usr/lib/go-gentoo (pkg and src files, which are only needed when a package is used as a library by another go package, and it isn't LXD's case). Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emulation/lxd/files')
-rw-r--r--app-emulation/lxd/files/lxd-2.17-dont-go-get.patch16
-rw-r--r--app-emulation/lxd/files/lxd-2.17.confd27
-rw-r--r--app-emulation/lxd/files/lxd-2.17.initd46
-rw-r--r--app-emulation/lxd/files/lxd-2.17.service10
4 files changed, 99 insertions, 0 deletions
diff --git a/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch b/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch
new file mode 100644
index 000000000000..a6e25e325b95
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17-dont-go-get.patch
@@ -0,0 +1,16 @@
+--- /src/github.com/lxc/lxd/Makefile.orig 2016-07-11 23:34:40.299664675 +0000
++++ /src/github.com/lxc/lxd/Makefile 2016-07-11 23:37:00.816018727 +0000
+@@ -13,13 +13,11 @@
+
+ .PHONY: default
+ default:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./...
+ @echo "LXD built successfully"
+
+ .PHONY: client
+ client:
+- go get -t -v -d ./...
+ go install -v $(TAGS) $(DEBUG) ./lxc
+ @echo "LXD client built successfully"
+
diff --git a/app-emulation/lxd/files/lxd-2.17.confd b/app-emulation/lxd/files/lxd-2.17.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-2.17.initd b/app-emulation/lxd/files/lxd-2.17.initd
new file mode 100644
index 000000000000..51c8e7e06553
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.initd
@@ -0,0 +1,46 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+}
+
+start() {
+ ebegin "Starting lxd server"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [ "$RC_GOINGDOWN" = "YES" ] || [ "$RC_REBOOT" = "YES" ]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/files/lxd-2.17.service b/app-emulation/lxd/files/lxd-2.17.service
new file mode 100644
index 000000000000..d00635fbcdd9
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-2.17.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Container hypervisor based on LXC
+
+[Service]
+ExecStart=/usr/sbin/lxd --group lxd
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target