summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-09-06 16:51:45 -0700
committerZac Medico <zmedico@gentoo.org>2019-09-06 16:52:04 -0700
commit8b321ed35ee70fd661b5e29ac39d22d413d19db1 (patch)
tree2817195dde38ce4b8213172fb8bc25dba9e03734 /app-emulation/skopeo
parentapp-emulation/reg: Fix compile with go-1.13 (diff)
downloadgentoo-8b321ed35ee70fd661b5e29ac39d22d413d19db1.tar.gz
gentoo-8b321ed35ee70fd661b5e29ac39d22d413d19db1.tar.bz2
gentoo-8b321ed35ee70fd661b5e29ac39d22d413d19db1.zip
app-emulation/skopeo: Use GO111MODULE=on for -mod=vendor backward compat
Use GO111MODULE=on together with -mod=vendor since otherwise -mod=vendor fails with go-1.12 like this: build flag -mod=vendor only valid when using modules Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/skopeo')
-rw-r--r--app-emulation/skopeo/skopeo-0.1.39.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-emulation/skopeo/skopeo-0.1.39.ebuild b/app-emulation/skopeo/skopeo-0.1.39.ebuild
index 80e35c4d984b..3af894ea4f9a 100644
--- a/app-emulation/skopeo/skopeo-0.1.39.ebuild
+++ b/app-emulation/skopeo/skopeo-0.1.39.ebuild
@@ -30,9 +30,8 @@ RESTRICT="test"
src_compile() {
local BUILDTAGS="containers_image_ostree_stub"
- set -- env -u GOCACHE -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" \
- go build $(has_version -b '>=dev-lang/go-1.13' && printf -- -mod=vendor) \
- -ldflags "-X main.gitCommit=${COMMIT}" \
+ set -- env -u GOCACHE -u XDG_CACHE_HOME GO111MODULE=on GOPATH="${WORKDIR}/${P}" \
+ go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
-gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
-o skopeo ./cmd/skopeo
echo "$@"