summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-20 00:47:02 +0100
committerSam James <sam@gentoo.org>2022-08-20 00:47:02 +0100
commitc4dba51dff6bf892456ab503ed10ad2b8b657cb0 (patch)
tree46494d2ce27cab38dc7f79903e4bf03519e86b8c /app-emulation/virt-manager
parentapp-emulation/virt-manager: update live (diff)
downloadgentoo-c4dba51dff6bf892456ab503ed10ad2b8b657cb0.tar.gz
gentoo-c4dba51dff6bf892456ab503ed10ad2b8b657cb0.tar.bz2
gentoo-c4dba51dff6bf892456ab503ed10ad2b8b657cb0.zip
app-emulation/virt-manager: enable tests, switch to USE=gui
Switch to USE=gui per QA policy [0] [0] https://projects.gentoo.org/qa/policy-guide/use-flags.html#pg0802 Closes: https://bugs.gentoo.org/795912 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/virt-manager-4.1.0.ebuild69
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild69
2 files changed, 84 insertions, 54 deletions
diff --git a/app-emulation/virt-manager/virt-manager-4.1.0.ebuild b/app-emulation/virt-manager/virt-manager-4.1.0.ebuild
index 1957dacecac0..bfa4c0d573fd 100644
--- a/app-emulation/virt-manager/virt-manager-4.1.0.ebuild
+++ b/app-emulation/virt-manager/virt-manager-4.1.0.ebuild
@@ -5,29 +5,39 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_SINGLE_IMPL=1
-
DISTUTILS_USE_SETUPTOOLS=no
inherit gnome2 distutils-r1 optfeature
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="https://virt-manager.org https://github.com/virt-manager/virt-manager"
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- SRC_URI=""
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/virt-manager/virt-manager.git"
EGIT_BRANCH="main"
+ SRC_URI=""
+ inherit git-r3
else
- SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+ SRC_URI="https://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="gtk policykit sasl"
+IUSE="gui policykit sasl"
-RDEPEND="${PYTHON_DEPS}
- gtk? (
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-cdr/cdrtools
+ >=app-emulation/libvirt-glib-1.0.0[introspection]
+ >=sys-libs/libosinfo-0.2.10[introspection]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gui? (
>=net-libs/gtk-vnc-0.3.8[gtk3(+),introspection]
gnome-base/dconf
net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
@@ -37,24 +47,27 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/gtksourceview:4[introspection]
x11-libs/vte:2.91[introspection]
)
- app-cdr/cdrtools
- >=app-emulation/libvirt-glib-1.0.0[introspection]
- $(python_gen_cond_dep '
- >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- >=sys-libs/libosinfo-0.2.10[introspection]
- "
+"
DEPEND="${RDEPEND}"
BDEPEND="dev-python/docutils"
DOCS=( README.md NEWS.md )
# Doesn't seem to play nicely in a sandboxed environment.
-RESTRICT="test"
+#RESTRICT="test"
+
+DISTUTILS_ARGS=(
+ --no-update-icon-cache
+ --no-compile-schemas
+)
+
+EPYTEST_IGNORE=(
+ # Wants to use /tmp osinfo config?
+ tests/test_cli.py
+
+ # These seem to be essentially coverage tests
+ tests/test_checkprops.py
+)
distutils_enable_tests pytest
@@ -62,17 +75,18 @@ python_configure() {
esetup.py configure --default-graphics=spice
}
-python_install() {
- esetup.py install
+python_test() {
+ export VIRTINST_TEST_SUITE_FORCE_LIBOSINFO=0
+
+ epytest
}
-src_install() {
- local DISTUTILS_ARGS=( --no-update-icon-cache --no-compile-schemas )
- distutils-r1_src_install
+python_install() {
+ esetup.py install
}
pkg_preinst() {
- if use gtk; then
+ if use gui ; then
gnome2_pkg_preinst
cd "${ED}" || die
@@ -87,7 +101,8 @@ pkg_preinst() {
}
pkg_postinst() {
- use gtk && gnome2_pkg_postinst
+ use gui && gnome2_pkg_postinst
+
optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
optfeature "QEMU host support" app-emulation/qemu[usbredir,spice]
}
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 1957dacecac0..bfa4c0d573fd 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -5,29 +5,39 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_SINGLE_IMPL=1
-
DISTUTILS_USE_SETUPTOOLS=no
inherit gnome2 distutils-r1 optfeature
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="https://virt-manager.org https://github.com/virt-manager/virt-manager"
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- SRC_URI=""
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/virt-manager/virt-manager.git"
EGIT_BRANCH="main"
+ SRC_URI=""
+ inherit git-r3
else
- SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+ SRC_URI="https://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="gtk policykit sasl"
+IUSE="gui policykit sasl"
-RDEPEND="${PYTHON_DEPS}
- gtk? (
+RDEPEND="
+ ${PYTHON_DEPS}
+ app-cdr/cdrtools
+ >=app-emulation/libvirt-glib-1.0.0[introspection]
+ >=sys-libs/libosinfo-0.2.10[introspection]
+ $(python_gen_cond_dep '
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ gui? (
>=net-libs/gtk-vnc-0.3.8[gtk3(+),introspection]
gnome-base/dconf
net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
@@ -37,24 +47,27 @@ RDEPEND="${PYTHON_DEPS}
x11-libs/gtksourceview:4[introspection]
x11-libs/vte:2.91[introspection]
)
- app-cdr/cdrtools
- >=app-emulation/libvirt-glib-1.0.0[introspection]
- $(python_gen_cond_dep '
- >=dev-python/libvirt-python-6.10.0[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/argcomplete[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- >=sys-libs/libosinfo-0.2.10[introspection]
- "
+"
DEPEND="${RDEPEND}"
BDEPEND="dev-python/docutils"
DOCS=( README.md NEWS.md )
# Doesn't seem to play nicely in a sandboxed environment.
-RESTRICT="test"
+#RESTRICT="test"
+
+DISTUTILS_ARGS=(
+ --no-update-icon-cache
+ --no-compile-schemas
+)
+
+EPYTEST_IGNORE=(
+ # Wants to use /tmp osinfo config?
+ tests/test_cli.py
+
+ # These seem to be essentially coverage tests
+ tests/test_checkprops.py
+)
distutils_enable_tests pytest
@@ -62,17 +75,18 @@ python_configure() {
esetup.py configure --default-graphics=spice
}
-python_install() {
- esetup.py install
+python_test() {
+ export VIRTINST_TEST_SUITE_FORCE_LIBOSINFO=0
+
+ epytest
}
-src_install() {
- local DISTUTILS_ARGS=( --no-update-icon-cache --no-compile-schemas )
- distutils-r1_src_install
+python_install() {
+ esetup.py install
}
pkg_preinst() {
- if use gtk; then
+ if use gui ; then
gnome2_pkg_preinst
cd "${ED}" || die
@@ -87,7 +101,8 @@ pkg_preinst() {
}
pkg_postinst() {
- use gtk && gnome2_pkg_postinst
+ use gui && gnome2_pkg_postinst
+
optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
optfeature "QEMU host support" app-emulation/qemu[usbredir,spice]
}