summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-03 15:08:13 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-03 16:34:03 +0200
commit429536804c65445a2c663c149dd6ee21502b2115 (patch)
treebb373ec0c75e76a91b774e5b38be7fcc81a3de53 /app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild
parentapp-emulation/virtualbox: fix compilation with gcc-13 (diff)
downloadgentoo-429536804c65445a2c663c149dd6ee21502b2115.tar.gz
gentoo-429536804c65445a2c663c149dd6ee21502b2115.tar.bz2
gentoo-429536804c65445a2c663c149dd6ee21502b2115.zip
app-emulation/virtualbox: pregen help
USE=doc pulls quite a lot of packages, including tex. They were used for the pdf manual, but now the manual also comes in qt help format. Pregenerate the help files and install them for USE=gui if USE=doc is disabled. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29405 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild')
-rw-r--r--app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild b/app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild
index 03eb7240d866..e5a64541f0f7 100644
--- a/app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild
+++ b/app-emulation/virtualbox/virtualbox-7.0.6-r2.ebuild
@@ -25,8 +25,11 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Family of powerful x86 virtualization products for enterprise and home use"
HOMEPAGE="https://www.virtualbox.org/"
-SRC_URI="https://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2
- https://gitweb.gentoo.org/proj/virtualbox-patches.git/snapshot/virtualbox-patches-6.1.36.tar.bz2"
+SRC_URI="
+ https://download.virtualbox.org/virtualbox/${PV}/${MY_P}.tar.bz2
+ https://gitweb.gentoo.org/proj/virtualbox-patches.git/snapshot/virtualbox-patches-6.1.36.tar.bz2
+ gui? ( !doc? ( https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${PN}-help-${PV}.tar.xz ) )
+"
S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="GPL-2+ GPL-3 LGPL-2.1 MIT dtrace? ( CDDL )"
@@ -225,11 +228,6 @@ pkg_pretend() {
einfo "will have NLS support."
fi
- if use gui && ! use doc; then
- einfo "You have disabled the \"doc\" USE flag. Built-in help"
- einfo "will not be available."
- fi
-
# 749273
local d=${ROOT}
for i in usr "$(get_libdir)"; do
@@ -677,6 +675,9 @@ src_install() {
if use doc; then
dodoc UserManual.pdf UserManual.q{ch,hc}
docompress -x /usr/share/doc/${PF}
+ elif use gui; then
+ dodoc "${WORKDIR}"/${PN}-help-${PV}/UserManual.q{ch,hc}
+ docompress -x /usr/share/doc/${PF}
fi
if use python; then