summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-12-02 12:20:33 +0100
committerSam James <sam@gentoo.org>2024-12-02 14:47:52 +0000
commit1be43cc3a111c3a862151f0926a4d144f2bc5150 (patch)
tree897fa649db885741046f302fd82442ec62a032e2 /app-emulation
parentapp-emulation/qemu-guest-agent: Ensure pip is available (diff)
downloadgentoo-1be43cc3a111c3a862151f0926a4d144f2bc5150.tar.gz
gentoo-1be43cc3a111c3a862151f0926a4d144f2bc5150.tar.bz2
gentoo-1be43cc3a111c3a862151f0926a4d144f2bc5150.zip
app-emulation/qemu: Update live ebuild
In qemu upstream, sh4eb-softmmu target was removed in [1], but then reverted in [2]. Reflect this change in the live ebuild. This partially reverts 64427d3372c8975a015875526ad546447c64bd48. Then, due to context changes, qemu-9.1.0-capstone-include-path.patch no longer applies cleanly. Rebase the patch. 1: https://gitlab.com/qemu-project/qemu/-/commit/73ceb12960e686b763415f0880cc5171ccce01cf 2: https://gitlab.com/qemu-project/qemu/-/commit/51cdb6806f405062c2bda3f527e98aaf259d6116 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/files/qemu-9.2.0-capstone-include-path.patch41
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild4
2 files changed, 43 insertions, 2 deletions
diff --git a/app-emulation/qemu/files/qemu-9.2.0-capstone-include-path.patch b/app-emulation/qemu/files/qemu-9.2.0-capstone-include-path.patch
new file mode 100644
index 000000000000..8cb557b59bce
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-9.2.0-capstone-include-path.patch
@@ -0,0 +1,41 @@
+From: Sam James <sam@gentoo.org>
+Date: Sun, 6 Oct 2024 09:47:03 +0100
+Subject: [PATCH] Forward ported from qemu-7.1.0-capstone-include-path.patch.
+
+Bug: https://bugs.gentoo.org/873157
+Signed-off-by: Sam James <sam@gentoo.org>
+Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
+---
+ include/disas/capstone.h | 2 +-
+ meson.build | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/include/disas/capstone.h b/include/disas/capstone.h
+index c43033f7f6..02bc067cd8 100644
+--- a/include/disas/capstone.h
++++ b/include/disas/capstone.h
+@@ -5,7 +5,7 @@
+
+ #define CAPSTONE_AARCH64_COMPAT_HEADER
+ #define CAPSTONE_SYSTEMZ_COMPAT_HEADER
+-#include <capstone.h>
++#include <capstone/capstone.h>
+
+ #else
+
+diff --git a/meson.build b/meson.build
+index 2c924f8f10..86858a325b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1892,7 +1892,7 @@ if not get_option('capstone').auto() or have_system or have_user
+ # that reports a wrong -I path, causing the #include to
+ # fail later. If the system has such a broken version
+ # do not use it.
+- if capstone.found() and not cc.compiles('#include <capstone.h>',
++ if capstone.found() and not cc.compiles('#include <capstone/capstone.h>',
+ dependencies: [capstone])
+ capstone = not_found
+ if get_option('capstone').enabled()
+--
+2.45.2
+
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 3de17faf48a3..e4f3ea185d13 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -90,6 +90,7 @@ COMMON_TARGETS="
riscv64
s390x
sh4
+ sh4eb
sparc
sparc64
x86_64
@@ -110,7 +111,6 @@ IUSE_USER_TARGETS="
mipsn32
mipsn32el
ppc64le
- sh4eb
sparc32plus
"
@@ -316,7 +316,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-9.0.0-disable-keymap.patch
- "${FILESDIR}"/${PN}-9.1.0-capstone-include-path.patch
+ "${FILESDIR}"/${PN}-9.2.0-capstone-include-path.patch
"${FILESDIR}"/${PN}-8.1.0-skip-tests.patch
"${FILESDIR}"/${PN}-8.1.0-find-sphinx.patch