summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-18 00:56:47 +0000
committerSam James <sam@gentoo.org>2023-03-18 01:19:36 +0000
commit4c9db83593638c20fb473c6714f4888b900eae62 (patch)
treedfe60f7cf2a5321d231e6d27e16da4603654e0a7 /app-emulation
parentdev-ruby/pg: fix whitespace (diff)
downloadgentoo-4c9db83593638c20fb473c6714f4888b900eae62.tar.gz
gentoo-4c9db83593638c20fb473c6714f4888b900eae62.tar.bz2
gentoo-4c9db83593638c20fb473c6714f4888b900eae62.zip
app-emulation/vagrant: drop 2.2.18-r1, 2.2.19
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.2.18-r1.ebuild95
-rw-r--r--app-emulation/vagrant/vagrant-2.2.19.ebuild95
3 files changed, 0 insertions, 191 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 75502f75960e..5d7e68811a33 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,2 +1 @@
-DIST vagrant-2.2.18.tar.gz 1620261 BLAKE2B 8938801b383373967365ca64a79f70885a61c02221eeebf75f15fa40440dfdc585f0a0d0cafe9a01484d594dc49b98397a0724776586c2c9fe4f529b6891bb26 SHA512 4694ca499136b53fc5cbab1efd47c9175293ba84521614edbe545766b93e54dc8dc11278f7170c88f3bb05a4ca0a7c52e21deca285f848578a890858b8f21b64
DIST vagrant-2.2.19.tar.gz 1838272 BLAKE2B cb707254379f52db8571bfe132e5b852a11998d86b43ee707e03d442ca1313da7b2612af027a58f806e0b551a6f415d121dab51cf7ea5da4292e5c2afd198ab9 SHA512 24a2e5baeac5cf8c45c012cf70dd4132b1dc7a6a5bab19d1046c91cc88e669356e2e5676d96eda6ed7293ff19ada974954969a4a59b9e4a30e2d95de27fa64e4
diff --git a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild b/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
deleted file mode 100644
index ddb8fa90f82a..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.18-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 optfeature ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${RDEPEND}
- app-arch/libarchive
- net-misc/curl
-"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-4.0.0
- >=dev-ruby/ed25519-1.2.4
- dev-ruby/erubi
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.8:1
- >=dev-ruby/listen-3.1
- <dev-ruby/log4r-1.1.11
- >=dev-ruby/mime-types-3.3:*
- >=dev-ruby/rubyzip-2.0
- >=dev-ruby/net-scp-3.0.0
- >=dev-ruby/net-sftp-3.0
- >=dev-ruby/net-ssh-6.1.0
- dev-ruby/rest-client:2
- >=dev-ruby/vagrant_cloud-3.0.5
- >=dev-ruby/rexml-3.2.5
-"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-12.3.3
- test? (
- dev-ruby/rspec
- dev-ruby/rspec-its
- dev-ruby/webmock
- )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
- rm tasks/bundler.rake || die
-
- sed -e ':rake\|rspec\|webmock: s:~>:>=:' \
- -e ':bcrypt_pbkdf\|hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|net-sftp\|childprocess: s:~>:>=:' \
- -e '/fake_ftp/ s:^#*:#:' \
- -e '/wdm/ s:^#*:#:' \
- -e '/winrm/ s:^#*:#:' \
- -e '/rb-kqueue/ s:^#*:#:' \
- -e '/ruby_dep/ s:^#*:#:' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-
- optfeature_header "Optional emulation/container backends:"
- optfeature "VirtualBox support" app-emulation/virtualbox
- optfeature "Docker support" app-containers/docker
-}
diff --git a/app-emulation/vagrant/vagrant-2.2.19.ebuild b/app-emulation/vagrant/vagrant-2.2.19.ebuild
deleted file mode 100644
index 3dde73808665..000000000000
--- a/app-emulation/vagrant/vagrant-2.2.19.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 optfeature ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${RDEPEND}
- app-arch/libarchive
- net-misc/curl
-"
-
-ruby_add_rdepend "
- >=dev-ruby/bcrypt_pbkdf-1.0.0
- >=dev-ruby/childprocess-4.0.0
- >=dev-ruby/ed25519-1.2.4
- dev-ruby/erubi
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/i18n-1.8:1
- >=dev-ruby/listen-3.1
- <dev-ruby/log4r-1.1.11
- >=dev-ruby/mime-types-3.3:*
- >=dev-ruby/rubyzip-2.0
- >=dev-ruby/net-scp-3.0.0
- >=dev-ruby/net-sftp-3.0
- >=dev-ruby/net-ssh-6.1.0
- dev-ruby/rest-client:2
- >=dev-ruby/vagrant_cloud-3.0.5
- >=dev-ruby/rexml-3.2.5
-"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-12.3.3
- test? (
- dev-ruby/rspec
- dev-ruby/rspec-its
- dev-ruby/webmock
- )
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
- rm tasks/bundler.rake || die
-
- sed -e ':rake\|rspec\|webmock: s:~>:>=:' \
- -e ':bcrypt_pbkdf\|hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|net-sftp\|childprocess: s:~>:>=:' \
- -e '/fake_ftp/ s:^#*:#:' \
- -e '/wdm/ s:^#*:#:' \
- -e '/winrm/ s:^#*:#:' \
- -e '/rb-kqueue/ s:^#*:#:' \
- -e '/ruby_dep/ s:^#*:#:' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp contrib/bash/completion.sh ${PN}
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-
- insinto /usr/share/vim/vimfiles/syntax/
- doins contrib/vim/vagrantfile.vim
-
- optfeature_header "Optional emulation/container backends:"
- optfeature "VirtualBox support" app-emulation/virtualbox
- optfeature "Docker support" app-containers/docker
-}