summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-03-21 21:45:46 +0100
committerPatrice Clement <monsieurp@gentoo.org>2021-03-21 21:45:59 +0100
commitc25482ba069212a7dd61659ca0c9c1abfed519c8 (patch)
tree37848ff339dfe7ec30e25c8d00c6a63a7c8ca092 /app-emulation
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-c25482ba069212a7dd61659ca0c9c1abfed519c8.tar.gz
gentoo-c25482ba069212a7dd61659ca0c9c1abfed519c8.tar.bz2
gentoo-c25482ba069212a7dd61659ca0c9c1abfed519c8.zip
app-emulation/nemu: version bump.
Courtesy of Nils Freydank <holgersson@posteo.de> Closes: https://bugs.gentoo.org/760606 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/nemu/Manifest1
-rw-r--r--app-emulation/nemu/nemu-2.5.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index e9544c5670d0..1a32c27e8017 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -1 +1,2 @@
DIST nemu-2.2.1.tar.gz 94600 BLAKE2B 16060ee1ed00f97a442d9f6b9a3f940d9777d24dea70336e382071ce7e9f7e077d58827110f4b0d64091c5777d516e95968ed0e1d4886b9fe2a3709fb466229d SHA512 e6f244c01582351f9e0f61a0a6848937a68b8d077500d0f8095784b871e9c9809bf5830c27918e84a77a64fcee3d6f81d8a06a031160f0beddc48614eb86624a
+DIST nemu-2.5.0.tar.gz 108742 BLAKE2B e68cbf50d56983873656d8e3428cb3ffaa09cafc9cbc8e545d72bf9dfb61e64a06bdc41c3f50011c4c488017efe33afe9fa1d634aae6e9151c45a7d3971c60db SHA512 081199413c41e545d23704091760c4a10b8dcdb21d9d0e6add1e549fa33bdd988490034767e08dee681eee6d06899104b8282cafc4578e06a0eabc505325bbdc
diff --git a/app-emulation/nemu/nemu-2.5.0.ebuild b/app-emulation/nemu/nemu-2.5.0.ebuild
new file mode 100644
index 000000000000..7747ae0c73a6
--- /dev/null
+++ b/app-emulation/nemu/nemu-2.5.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake linux-info
+
+MY_PV="${PV/_rc/-RC}"
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://github.com/nemuTUI/nemu"
+SRC_URI="https://github.com/nemuTUI/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus network-map +ovf +savevm spice +vnc-client"
+
+RDEPEND="
+ app-emulation/qemu[vnc,virtfs,spice?]
+ dev-db/sqlite:3=
+ sys-libs/ncurses:0=[unicode]
+ virtual/libusb:1
+ virtual/libudev:=
+ dbus? ( sys-apps/dbus )
+ network-map? ( media-gfx/graphviz[svg] )
+ ovf? (
+ dev-libs/libxml2:2
+ app-arch/libarchive
+ )
+ spice? ( app-emulation/virt-viewer )
+ vnc-client? ( net-misc/tigervnc )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+S="${WORKDIR}/$PN-${MY_PV}/"
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+ check_extra_config
+ fi
+ fi
+}
+
+src_configure() {
+ # -DNM_USE_UTF: Enable unicode unconditionally. We already
+ # depended on ncurses[unicode].
+ # -DNM_WITH_QEMU: Do not embbed qemu.
+ local mycmakeargs=(
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_USE_UTF=on
+ -DNM_WITH_DBUS=$(usex dbus)
+ -DNM_WITH_NETWORK_MAP=$(usex network-map)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ -DNM_WITH_QEMU=off
+ -DNM_WITH_SPICE=$(usex spice)
+ -DNM_WITH_VNC_CLIENT=$(usex vnc-client)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /etc/udev/rules.d"
+ elog "Afterwards reboot or reload udev with"
+ elog "udevadm control --reload-rules && udevadm trigger"
+}