summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2016-07-11 13:48:13 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2016-07-11 13:48:55 -0400
commitdd9a77d4bd4929d83b16c7d7ef8a364e254d2378 (patch)
treea23333123291d21282736b7b0bc864f219d20241 /app-emulation
parentprofiles/arch/powerpc/ppc32: move quassel qt5 flag back to package.use.mask (diff)
downloadgentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.tar.gz
gentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.tar.bz2
gentoo-dd9a77d4bd4929d83b16c7d7ef8a364e254d2378.zip
app-emulation/wine: Fix two QA issues, #588604
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-1.8-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.8.1-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.8.2-r1.ebuild17
-rw-r--r--app-emulation/wine/wine-1.8.2.ebuild2
-rw-r--r--app-emulation/wine/wine-1.8.3.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.10-r1.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.11-r1.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.12.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.13.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.4-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.5-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.6-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.7-r2.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.8-r1.ebuild17
-rw-r--r--app-emulation/wine/wine-1.9.9-r1.ebuild17
-rw-r--r--app-emulation/wine/wine-9999.ebuild17
16 files changed, 151 insertions, 106 deletions
diff --git a/app-emulation/wine/wine-1.8-r2.ebuild b/app-emulation/wine/wine-1.8-r2.ebuild
index 4675885485df..60871af5fe0f 100644
--- a/app-emulation/wine/wine-1.8-r2.ebuild
+++ b/app-emulation/wine/wine-1.8-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+VANILLA_GV="2.40"
+VANILLA_MV="4.5.6"
STAGING_GV="2.40"
STAGING_MV="4.5.6"
STAGING_P="wine-staging-${PV}"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -261,7 +261,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -341,7 +344,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.8.1-r2.ebuild b/app-emulation/wine/wine-1.8.1-r2.ebuild
index fb7173254b74..79bcfa04127b 100644
--- a/app-emulation/wine/wine-1.8.1-r2.ebuild
+++ b/app-emulation/wine/wine-1.8.1-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+VANILLA_GV="2.40"
+VANILLA_MV="4.5.6"
STAGING_GV="2.40"
STAGING_MV="4.5.6"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -35,10 +35,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -262,7 +262,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -347,7 +350,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.8.2-r1.ebuild b/app-emulation/wine/wine-1.8.2-r1.ebuild
index 6d7436a6108a..772d165365dd 100644
--- a/app-emulation/wine/wine-1.8.2-r1.ebuild
+++ b/app-emulation/wine/wine-1.8.2-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+VANILLA_GV="2.40"
+VANILLA_MV="4.5.6"
STAGING_GV="2.40"
STAGING_MV="4.5.6"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -35,10 +35,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -262,7 +262,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -347,7 +350,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.8.2.ebuild b/app-emulation/wine/wine-1.8.2.ebuild
index 0da62bb62dd6..d9b63719607d 100644
--- a/app-emulation/wine/wine-1.8.2.ebuild
+++ b/app-emulation/wine/wine-1.8.2.ebuild
@@ -314,7 +314,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.8.3.ebuild b/app-emulation/wine/wine-1.8.3.ebuild
index 6d397103168a..1feebaeccc07 100644
--- a/app-emulation/wine/wine-1.8.3.ebuild
+++ b/app-emulation/wine/wine-1.8.3.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.40"
-MV="4.5.6"
+VANILLA_GV="2.40"
+VANILLA_MV="4.5.6"
STAGING_GV="2.40"
STAGING_MV="4.5.6"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -35,10 +35,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -262,7 +262,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -346,7 +349,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.10-r1.ebuild b/app-emulation/wine/wine-1.9.10-r1.ebuild
index 97400a546d5d..33c7d8f4f51b 100644
--- a/app-emulation/wine/wine-1.9.10-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.10-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.2"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.2"
STAGING_GV="2.47-beta1"
STAGING_MV="4.6.2"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -360,7 +363,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.11-r1.ebuild b/app-emulation/wine/wine-1.9.11-r1.ebuild
index 97400a546d5d..33c7d8f4f51b 100644
--- a/app-emulation/wine/wine-1.9.11-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.11-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.2"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.2"
STAGING_GV="2.47-beta1"
STAGING_MV="4.6.2"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -360,7 +363,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.12.ebuild b/app-emulation/wine/wine-1.9.12.ebuild
index 1c8e112b1a6a..d5f0bad64a84 100644
--- a/app-emulation/wine/wine-1.9.12.ebuild
+++ b/app-emulation/wine/wine-1.9.12.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.3"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.3"
STAGING_GV="2.47-beta1"
STAGING_MV="4.6.3"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -360,7 +363,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.13.ebuild b/app-emulation/wine/wine-1.9.13.ebuild
index 5da73b4d9403..c637572cb619 100644
--- a/app-emulation/wine/wine-1.9.13.ebuild
+++ b/app-emulation/wine/wine-1.9.13.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.47"
-MV="4.6.3"
+VANILLA_GV="2.47"
+VANILLA_MV="4.6.3"
STAGING_GV="2.47"
STAGING_MV="4.6.3"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -359,7 +362,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.4-r2.ebuild b/app-emulation/wine/wine-1.9.4-r2.ebuild
index e72fc4972c3c..0f6ce355c564 100644
--- a/app-emulation/wine/wine-1.9.4-r2.ebuild
+++ b/app-emulation/wine/wine-1.9.4-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.5.6"
+VANILLA_GV="2.44"
+VANILLA_MV="4.5.6"
STAGING_GV="2.44"
STAGING_MV="4.5.6"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -260,7 +260,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -343,7 +346,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.5-r2.ebuild b/app-emulation/wine/wine-1.9.5-r2.ebuild
index a2e4f3ed1376..717ef85883bc 100644
--- a/app-emulation/wine/wine-1.9.5-r2.ebuild
+++ b/app-emulation/wine/wine-1.9.5-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.0"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.0"
STAGING_GV="2.44"
STAGING_MV="4.6.0"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -259,7 +259,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -345,7 +348,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.6-r2.ebuild b/app-emulation/wine/wine-1.9.6-r2.ebuild
index 47058cbbb024..c52e2472d1b8 100644
--- a/app-emulation/wine/wine-1.9.6-r2.ebuild
+++ b/app-emulation/wine/wine-1.9.6-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.0"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.0"
STAGING_GV="2.44"
STAGING_MV="4.6.0"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -259,7 +259,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -342,7 +345,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.7-r2.ebuild b/app-emulation/wine/wine-1.9.7-r2.ebuild
index 47058cbbb024..c52e2472d1b8 100644
--- a/app-emulation/wine/wine-1.9.7-r2.ebuild
+++ b/app-emulation/wine/wine-1.9.7-r2.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.0"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.0"
STAGING_GV="2.44"
STAGING_MV="4.6.0"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -259,7 +259,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -342,7 +345,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.8-r1.ebuild b/app-emulation/wine/wine-1.9.8-r1.ebuild
index c886ca7267d1..2db9e5bfbea1 100644
--- a/app-emulation/wine/wine-1.9.8-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.8-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.2"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.2"
STAGING_GV="2.44"
STAGING_MV="4.6.2"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -34,10 +34,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -259,7 +259,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -342,7 +345,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-1.9.9-r1.ebuild b/app-emulation/wine/wine-1.9.9-r1.ebuild
index 34d2b890b0f2..ef7d72ca46d6 100644
--- a/app-emulation/wine/wine-1.9.9-r1.ebuild
+++ b/app-emulation/wine/wine-1.9.9-r1.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.44"
-MV="4.6.2"
+VANILLA_GV="2.44"
+VANILLA_MV="4.6.2"
STAGING_GV="2.44"
STAGING_MV="4.6.2"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -360,7 +363,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 5da73b4d9403..c637572cb619 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -21,8 +21,8 @@ else
KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
fi
-GV="2.47"
-MV="4.6.3"
+VANILLA_GV="2.47"
+VANILLA_MV="4.6.3"
STAGING_GV="2.47"
STAGING_MV="4.6.3"
[[ ${MAJOR_V} == "1.8" ]] && SUFFIX="-unofficial"
@@ -36,10 +36,10 @@ HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
!staging? (
gecko? (
- abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ abi_x86_32? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/wine-gecko/${VANILLA_GV}/wine_gecko-${VANILLA_GV}-x86_64.msi )
)
- mono? ( https://dl.winehq.org/wine/wine-mono/${MV}/wine-mono-${MV}.msi )
+ mono? ( https://dl.winehq.org/wine/wine-mono/${VANILLA_MV}/wine-mono-${VANILLA_MV}.msi )
)
staging? (
gecko? (
@@ -264,7 +264,10 @@ pkg_pretend() {
pkg_setup() {
wine_build_environment_check || die
- if use staging; then
+ if ! use staging; then
+ GV=${VANILLA_GV}
+ MV=${VANILLA_MV}
+ else
GV=${STAGING_GV}
MV=${STAGING_MV}
fi
@@ -359,7 +362,7 @@ src_prepare() {
# hi-res default icon, #472990, http://bugs.winehq.org/show_bug.cgi?id=24652
cp "${WORKDIR}"/${WINE_GENTOO}/icons/oic_winlogo.ico dlls/user32/resources/ || die
- l10n_get_locales > po/LINGUAS # otherwise wine doesn't respect LINGUAS
+ l10n_get_locales > po/LINGUAS || die # otherwise wine doesn't respect LINGUAS
}
src_configure() {