summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-07-26 22:58:33 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-07-26 23:00:32 -0400
commit49ab2317e4577179b8a2655479dd43d4dbd1d02c (patch)
tree371e18e52d5633b956cb09c128d2fb8cb344559d /app-eselect/eselect-php
parentapp-eselect/eselect-php: update EAPI 7 -> 8 in the live ebuild (diff)
downloadgentoo-49ab2317e4577179b8a2655479dd43d4dbd1d02c.tar.gz
gentoo-49ab2317e4577179b8a2655479dd43d4dbd1d02c.tar.bz2
gentoo-49ab2317e4577179b8a2655479dd43d4dbd1d02c.zip
app-eselect/eselect-php: add 0.9.9
Closes: https://bugs.gentoo.org/910589 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-php')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index c9f6d55d8333..9ba5d385970f 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1 +1,2 @@
DIST eselect-php-0.9.8.tar.xz 62048 BLAKE2B 7938053be5d3893d1b3b399decb9fb90ecc1d266edcee7192511c63ccdd21fb0e7deac2b654db3dc05f56de7c757bb34ed813a026fc711adc4ab05b373f3d275 SHA512 c947d303dc0406539017f3779a7ee1e51e670ce73a47e1a6722f8403573a5dae0825c3b6932d12123bab77187a515023b69fc771f24522480e74fa0287377c3c
+DIST eselect-php-0.9.9.tar.xz 54632 BLAKE2B bdd8cb3fafbef057e068c57b413bf3ff03be324c9d0e4938342204780cc15ee9fd415757b1293892032901fb041746cc59f912783cea9dc04b52559d3d6f2415 SHA512 9a86986f9be05fe3c0796bf10dae9de7c9c2c57944d24ea202c6537ad185e4eea915d67befee27ce1c0e3908890661bf384bd54b1b421ec2b928776485da0364
diff --git a/app-eselect/eselect-php/eselect-php-0.9.9.ebuild b/app-eselect/eselect-php/eselect-php-0.9.9.ebuild
new file mode 100644
index 000000000000..19f1e333d210
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+TMPFILES_OPTIONAL="yes"
+inherit tmpfiles
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
+
+src_configure() {
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ #
+ # The libdir is passed explicitly in case the /usr/lib symlink
+ # is not present (bug 624528).
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-piddir="${EPREFIX}/run" \
+ $(use_enable apache2) \
+ $(use_enable fpm)
+}
+
+pkg_postinst() {
+ use fpm && tmpfiles_process php-fpm.conf
+}