summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-25 08:39:03 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-25 08:58:30 +0100
commit0f7242503f8c29d811ae0023550bbf2e74c55ac6 (patch)
treed9b6fe8b5ea12aec69d146f924962e97ebde4405 /app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild
parentdev-ruby/atomic: amd64 stable (diff)
downloadgentoo-0f7242503f8c29d811ae0023550bbf2e74c55ac6.tar.gz
gentoo-0f7242503f8c29d811ae0023550bbf2e74c55ac6.tar.bz2
gentoo-0f7242503f8c29d811ae0023550bbf2e74c55ac6.zip
app-eselect/eselect-ruby: add support for ruby25
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild')
-rw-r--r--app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild b/app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild
new file mode 100644
index 000000000000..8cd0413703da
--- /dev/null
+++ b/app-eselect/eselect-ruby/eselect-ruby-20171225.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Manages multiple Ruby versions"
+HOMEPAGE="https://www.gentoo.org"
+SRC_URI="https://dev.gentoo.org/~graaff/ruby-team/ruby.eselect-${PVR}.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.0.2"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${WORKDIR}/ruby.eselect-${PVR}" ruby.eselect || die
+}