summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-11-08 18:40:41 +0100
committerPacho Ramos <pacho@gentoo.org>2024-11-08 19:16:06 +0100
commit17ac84afb75d46847593001a845df335171cfd43 (patch)
treed054fce21f5aecf2ac75259874a771569d2627f3 /app-i18n
parentdev-python/pyclipper: drop myself as a maintainer (diff)
downloadgentoo-17ac84afb75d46847593001a845df335171cfd43.tar.gz
gentoo-17ac84afb75d46847593001a845df335171cfd43.tar.bz2
gentoo-17ac84afb75d46847593001a845df335171cfd43.zip
app-i18n/poedit: add 3.5.2
Closes: https://bugs.gentoo.org/917432 Closes: https://bugs.gentoo.org/934231 Closes: https://bugs.gentoo.org/935466 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/poedit/Manifest1
-rw-r--r--app-i18n/poedit/poedit-3.5.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/poedit/Manifest b/app-i18n/poedit/Manifest
index 9544b908f591..35b1043413fa 100644
--- a/app-i18n/poedit/Manifest
+++ b/app-i18n/poedit/Manifest
@@ -1,2 +1,3 @@
DIST poedit-2.2.4.tar.gz 2840389 BLAKE2B 1f88aeba2d4dc5ad802843cc39c298936d6619d98839257c302858f14f8d0ef3fabbda290d83192e501a7679ad2ebc63d1a87314e885d8d7e465b54de0feb297 SHA512 e7388e0657755752bc9eacd95d0a2f8f70d5a759fa15f054be3a8d07df821e8dceb9994652b576553808840bac520fcd292fd15987659f8cb4e4c8c7930ae919
DIST poedit-2.3.1.tar.gz 2891956 BLAKE2B 11fb8c19f439edc2c9df08529e815d47f5bdfe3cac486bd07bfaef90932edf05ce099b61f058d8d08ba1a3a41f35ed59bf2901de1d1d80ecc6178536cdcff908 SHA512 73439ae96d3e04d8f6fc7e49f72cd259606e669f01490bd9a59f3fa7b33a6e11fb3af70a3a6e155b1edcee49ac9222b16e05e937088748a9c0f3ed9a6c97a208
+DIST poedit-3.5.2.tar.gz 3173111 BLAKE2B 8e7ae9fc06af173107fa46fa4f07cab3637d75cd60bc8bc0d48df23cdc97434e05a55b2eb4e28295de4e0072ba43bb2078e51768294510946c0b400a028ccd5d SHA512 5728b23ae64751754f8d23e24ba12311bf55f6a0fee3ef44d74b78ed74ed5397e198353388dadb3ce217996ee5b09d9a8e963614ce78a62ce108d4fa22c1cdf1
diff --git a/app-i18n/poedit/poedit-3.5.2.ebuild b/app-i18n/poedit/poedit-3.5.2.ebuild
new file mode 100644
index 000000000000..267ecf3ae4dd
--- /dev/null
+++ b/app-i18n/poedit/poedit-3.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PLOCALES="af an ar az be bg bs ca ckb co cs da de el en_GB es et eu fa fi fr ga gl he hr hu hy id is it ja ka kab kk ko lt lv ms nb nl oc pa pl pt_BR pt_PT ro ru sk sl sq sr sv tg th tr uk uz vi zh_CN zh_TW"
+WX_GTK_VER=3.2-gtk3
+
+inherit gnome2-utils plocale wxwidgets xdg
+
+DESCRIPTION="GUI gettext translations editor"
+HOMEPAGE="https://poedit.net"
+SRC_URI="https://github.com/vslavik/${PN}/releases/download/v${PV}-oss/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-text/gtkspell:3
+ x11-libs/gtk+:3
+ >=dev-cpp/lucene++-3.0.5
+ >=dev-libs/pugixml-1.9
+ dev-libs/boost:=[nls]
+ dev-libs/icu:=
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit,X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ my_rm_loc() {
+ sed -i -e "/^POEDIT_LINGUAS = /s: ${1}::" locales/Makefile.in || die
+ rm "locales/${1}.mo" || die
+ }
+
+ plocale_find_changes 'locales' '' '.mo'
+ plocale_for_each_disabled_locale my_rm_loc
+
+ default
+}
+
+src_configure() {
+ setup-wxwidgets
+ # CLD2 and C++ Rest are not available in Gentoo, bug 674916
+ local myeconfargs=(
+ --without-cld2
+ --without-cpprest
+ )
+
+ econf "${myeconfargs[@]}"
+}