summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild')
-rw-r--r--app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild b/app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild
new file mode 100644
index 000000000000..def627388786
--- /dev/null
+++ b/app-leechcraft/lc-poshuku/lc-poshuku-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Poshuku, the full-featured web browser plugin for LeechCraft"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="+autosearch debug +dcac +cleanweb +fatape +filescheme +fua +idn +keywords +onlinebookmarks
+ +pcre postgres qrd +sqlite wyfv"
+
+DEPEND="~app-leechcraft/lc-core-${PV}[postgres?,sqlite?]
+ dev-qt/qtwebkit:4
+ idn? ( net-dns/libidn )
+ onlinebookmarks? ( >=dev-libs/qjson-0.7.1-r1 )
+ pcre? ( >=dev-libs/libpcre-8.12 )
+ qrd? ( media-gfx/qrencode )
+"
+RDEPEND="${DEPEND}
+ virtual/leechcraft-downloader-http"
+
+REQUIRED_USE="pcre? ( cleanweb )"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable autosearch POSHUKU_AUTOSEARCH)
+ $(cmake-utils_use_enable cleanweb POSHUKU_CLEANWEB)
+ $(cmake-utils_use_enable dcac POSHUKU_DCAC)
+ $(cmake-utils_use_enable fatape POSHUKU_FATAPE)
+ $(cmake-utils_use_enable filescheme POSHUKU_FILESCHEME)
+ $(cmake-utils_use_enable fua POSHUKU_FUA)
+ $(cmake-utils_use_enable idn IDN)
+ $(cmake-utils_use_enable keywords POSHUKU_KEYWORDS)
+ $(cmake-utils_use_enable onlinebookmarks POSHUKU_ONLINEBOOKMARKS)
+ $(cmake-utils_use_enable qrd POSHUKU_QRD)
+ $(cmake-utils_use_enable pcre POSHUKU_CLEANWEB_PCRE)
+ $(cmake-utils_use_enable wyfv POSHUKU_WYFV)
+ "
+
+ cmake-utils_src_configure
+}