summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-07-04 10:57:56 +0200
committerSam James <sam@gentoo.org>2024-07-08 15:27:54 +0100
commit2d7392d44f0a42531a0302be16a54ac8daabd6f4 (patch)
tree323d19b7ac3ce64f01e3d4b01e03d07d5b3793d5 /app-metrics
parentdev-python/pybind11: add patch for gcc14 (diff)
downloadgentoo-2d7392d44f0a42531a0302be16a54ac8daabd6f4.tar.gz
gentoo-2d7392d44f0a42531a0302be16a54ac8daabd6f4.tar.bz2
gentoo-2d7392d44f0a42531a0302be16a54ac8daabd6f4.zip
app-metrics/chrony_exporter: fix tests
Disable the race detector for tests, which are all simple single-threaded input/output verification. Closes: https://bugs.gentoo.org/935442 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/37424 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/chrony_exporter/chrony_exporter-0.10.1.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-metrics/chrony_exporter/chrony_exporter-0.10.1.ebuild b/app-metrics/chrony_exporter/chrony_exporter-0.10.1.ebuild
index b24bc02e2e57..d264fa860fc5 100644
--- a/app-metrics/chrony_exporter/chrony_exporter-0.10.1.ebuild
+++ b/app-metrics/chrony_exporter/chrony_exporter-0.10.1.ebuild
@@ -20,6 +20,12 @@ DEPEND="acct-group/chrony_exporter
BDEPEND="dev-util/promu"
+src_prepare() {
+ default
+ # No need to enable the race detector for tests (#935442)
+ sed -i -e '/test-flags := -race/d' Makefile.common || die
+}
+
src_compile() {
promu build -v --cgo --prefix bin || die
}