summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-06-07 13:17:23 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-06-07 13:17:42 -0700
commit13778f34d910b1f0d42bdf7b49575ea56f48171c (patch)
tree6131f6e81fc5af0dea65f0ae2febbf0cd247d0ff /app-misc/asciinema
parentnet-mail/amavis-logwatch: remove old v1.51.03 and its patches. (diff)
downloadgentoo-13778f34d910b1f0d42bdf7b49575ea56f48171c.tar.gz
gentoo-13778f34d910b1f0d42bdf7b49575ea56f48171c.tar.bz2
gentoo-13778f34d910b1f0d42bdf7b49575ea56f48171c.zip
app-misc/asciinema: add 2.2.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/asciinema')
-rw-r--r--app-misc/asciinema/Manifest1
-rw-r--r--app-misc/asciinema/asciinema-2.2.0.ebuild27
-rw-r--r--app-misc/asciinema/files/asciinema-2.2.0-setup.patch22
3 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/asciinema/Manifest b/app-misc/asciinema/Manifest
index df33f8c73503..eb2962653dc0 100644
--- a/app-misc/asciinema/Manifest
+++ b/app-misc/asciinema/Manifest
@@ -1 +1,2 @@
DIST asciinema-2.1.0.tar.gz 82022 BLAKE2B 2f7c68caef228a6cb98f3503212edc393bd8f7a3653a369b0509d45a6e19b8373630fac88498a771c0eaa2a322a95ab816b268660b8b2384d1ec25c617b06a5a SHA512 df77ccea13e06e9c5feda22be2366aa702acf510fdc6cbc9a09b20d67ae43a47214891fbb5ef080ff9af9c3ee2f450694c306ee1dbdbdef3f9862dc6dee60750
+DIST asciinema-2.2.0.tar.gz 88566 BLAKE2B c96eac56714a4519d462bdf24f3fcc0ec367af94182e6710d4744113c5ac3ec9304fbda30f3489b84bc4b645e43ea44d633230128d79a576d4bcbe7dad528ba8 SHA512 bed0b6a3228b973dddb2f03d0b0e16af0afd6e1c4c8c1379999d49b22ed658fed325f902f462156745631f98b51675565b7ea0011512c95c8b0b3bb09552bddc
diff --git a/app-misc/asciinema/asciinema-2.2.0.ebuild b/app-misc/asciinema/asciinema-2.2.0.ebuild
new file mode 100644
index 000000000000..468d6c304fa3
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.org/project/asciinema/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/asciinema-2.2.0-setup.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "s|share/doc/asciinema|&-${PVR}|" setup.cfg || die
+}
diff --git a/app-misc/asciinema/files/asciinema-2.2.0-setup.patch b/app-misc/asciinema/files/asciinema-2.2.0-setup.patch
new file mode 100644
index 000000000000..ae7630f21b62
--- /dev/null
+++ b/app-misc/asciinema/files/asciinema-2.2.0-setup.patch
@@ -0,0 +1,22 @@
+diff --git a/setup.cfg b/setup.cfg
+index 7e75a81..7f38a46 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -9,7 +9,8 @@ download_url =
+ description = Terminal session recorder
+ description_file = README.md
+ license = GNU GPLv3
+-license_file = LICENSE
++license_files =
++ LICENSE
+ long_description = file: README.md
+ long_description_content_type = text/markdown; charset=UTF-8
+ classifiers =
+@@ -35,6 +36,7 @@ packages =
+ asciinema
+ asciinema.asciicast
+ asciinema.commands
++ asciinema.data
+ install_requires =
+
+ [options.package_data]