summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-05-31 20:23:09 +0000
committerSam James <sam@gentoo.org>2022-05-31 23:12:08 +0100
commita0d4f1f14c8db221934ea0f1682fa9afe04c15a3 (patch)
tree630e181ce87457c18d7c2e05ed51dc2f25417642 /app-misc/chkcrontab
parentmedia-sound/easyeffects-6.2.5: die if <=gcc-10 is used (diff)
downloadgentoo-a0d4f1f14c8db221934ea0f1682fa9afe04c15a3.tar.gz
gentoo-a0d4f1f14c8db221934ea0f1682fa9afe04c15a3.tar.bz2
gentoo-a0d4f1f14c8db221934ea0f1682fa9afe04c15a3.zip
app-misc/chkcrontab: add python3.{10,11}
Closes: https://bugs.gentoo.org/845495 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25708 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/chkcrontab')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
new file mode 100644
index 000000000000..7eeb1c6d8f32
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}