summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/cw
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/cw')
-rw-r--r--app-misc/cw/Manifest1
-rw-r--r--app-misc/cw/cw-1.0.16-r3.ebuild63
-rw-r--r--app-misc/cw/files/1.0.16-collision.patch34
-rw-r--r--app-misc/cw/files/1.0.16-format-security.patch16
-rw-r--r--app-misc/cw/files/1.0.16-ldflags.patch18
-rw-r--r--app-misc/cw/files/1.0.16-path.patch19
-rw-r--r--app-misc/cw/metadata.xml8
7 files changed, 159 insertions, 0 deletions
diff --git a/app-misc/cw/Manifest b/app-misc/cw/Manifest
new file mode 100644
index 000000000000..b68084adf05b
--- /dev/null
+++ b/app-misc/cw/Manifest
@@ -0,0 +1 @@
+DIST cw-1.0.16.tar.bz2 76035 SHA256 a12738f13f3ee90b0bd0c875b4d0bd345d51dced6efd5a14dd82a4705c78fbe4 SHA512 6a5da4e4dbb4d042d8b4e1e0727039f3103f9d7124a6f7c37ac094d7fee0ae10d9bacc6739fc133ca9fb682501bcafecd39a660abfe19fbf1fd9bf7ec06cfa32 WHIRLPOOL 1e5188ac6a9c5985c0169a6a932e1fd7dec242a1e9dcf2409c0bf54161733feb26fb500ec0308d062dbffe595946d7adffe74a19a849420733931f092143cd1c
diff --git a/app-misc/cw/cw-1.0.16-r3.ebuild b/app-misc/cw/cw-1.0.16-r3.ebuild
new file mode 100644
index 000000000000..c032948da274
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-path.patch \
+ "${FILESDIR}"/${PV}-collision.patch \
+ "${FILESDIR}"/${PV}-format-security.patch
+ tc-export CC
+}
+
+src_compile() {
+ emake local
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/*
+
+ exeinto /usr/libexec/cw
+ doexe def/*
+
+ doman man/cwu*
+ newman man/cw.* color-wrapper
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README*
+
+ dobin bin/{cwu,colorcfg}
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+ # media-radio/unixcw currently conflicts;
+ newbin bin/cw color-wrapper
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/color-wrapper # >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}
diff --git a/app-misc/cw/files/1.0.16-collision.patch b/app-misc/cw/files/1.0.16-collision.patch
new file mode 100644
index 000000000000..52bb8cab8f3b
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-collision.patch
@@ -0,0 +1,34 @@
+diff --git a/src/cw.c b/src/cw.c
+index d7b4875..a7811d8 100644
+--- a/src/cw.c
++++ b/src/cw.c
+@@ -1336,7 +1336,7 @@ unsigned char is_cwfile(char *file){
+ s=strlen(buf);
+ if(buf[s]=='\n')s--;
+ if(buf[s]=='\r')s--;
+- if(s>4&&!strncmp(buf,"#!",2)&&!strncmp(buf+(s-4),"/cw",3))return(1);
++ if(s>15&&!strncmp(buf,"#!",2)&&!strncmp(buf+(s-15),"/color-wrapper",14))return(1);
+ return(0);
+ }
+ /* sets left and right borders. */
+diff --git a/src/cwu.c b/src/cwu.c
+index 823618d..63f566b 100644
+--- a/src/cwu.c
++++ b/src/cwu.c
+@@ -37,12 +37,12 @@ signed int main(signed int argc,char **argv){
+ if(argc>1&&!strcmp(argv[1],"-v"))
+ cwuexit(1,"cwu (color wrapper directive updater) v"VERSION);
+ if(argc<2)
+- cwuexit(1,"syntax: cwu <definitions directory> <cw binary path>");
++ cwuexit(1,"syntax: cwu <definitions directory> <color-wrapper binary path>");
+ if(argc<3)cwuexit(1,"no path provided to update with.");
+- if(strncmp(argv[2]+(strlen(argv[2])-3),"/cw",3))
+- cwuexit(1,"cw binary path doesn't end with `/cw'.");
++ if(strncmp(argv[2]+(strlen(argv[2])-14),"/color-wrapper",14))
++ cwuexit(1,"cw binary path doesn't end with `/color-wrapper'.");
+ if(access(argv[2],X_OK))
+- cwuexit(1,"cw binary does not exist or is not executable.");
++ cwuexit(1,"color-wrapper binary does not exist or is not executable.");
+ globcw(argv[1],argv[2]);
+ cwuexit(0,0);
+ exit(0);
diff --git a/app-misc/cw/files/1.0.16-format-security.patch b/app-misc/cw/files/1.0.16-format-security.patch
new file mode 100644
index 000000000000..20f0b1d06b1e
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-format-security.patch
@@ -0,0 +1,16 @@
+ src/cw.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/cw.c b/src/cw.c
+index d7b4875..3ec1ac1 100644
+--- a/src/cw.c
++++ b/src/cw.c
+@@ -643,7 +643,7 @@ void sighandler(signed int sig){
+ else if(sig==SIGUSR1)ext=1;
+ else if(sig==SIGALRM)ext=2;
+ else if(sig==SIGPIPE||sig==SIGINT){
+- fprintf(stderr,pal2[16]);
++ fprintf(stderr,"%s", pal2[16]);
+ fflush(stderr);
+ cwexit(0,0);
+ }
diff --git a/app-misc/cw/files/1.0.16-ldflags.patch b/app-misc/cw/files/1.0.16-ldflags.patch
new file mode 100644
index 000000000000..46037312c6c3
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-ldflags.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile.in b/Makefile.in
+index 9a6e4ec..e510493 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -19,11 +19,11 @@ all:
+
+ cw:
+ @$(ECHO) "* Compiling cw(color wrapper)..."
+- @$(CC) src/cw.c -o bin/cw @CFLAGS@ @LIBS@ @DEFS@
++ $(CC) $(CFLAGS) $(LDFLAGS) src/cw.c -o bin/cw @CFLAGS@ @LIBS@ @DEFS@
+
+ cwu:
+ @$(ECHO) "* Compiling cwu(color wrapper directive updater)..."
+- @$(CC) src/cwu.c -o bin/cwu @CFLAGS@
++ $(CC) $(CFLAGS) $(LDFLAGS) src/cwu.c -o bin/cwu
+
+ local: cw cwu
+
diff --git a/app-misc/cw/files/1.0.16-path.patch b/app-misc/cw/files/1.0.16-path.patch
new file mode 100644
index 000000000000..f62b5bd994d4
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-path.patch
@@ -0,0 +1,19 @@
+diff --git a/bin/colorcfg b/bin/colorcfg
+index cf73b50..3e78c73 100755
+--- a/bin/colorcfg
++++ b/bin/colorcfg
+@@ -10,13 +10,7 @@ echo "[ cw/color wrapper: user setup script. ]"
+ if test -x "${HOME}/.cw/bin/colorcfg";then
+ CWLIB="${HOME}/.cw/def"
+ else
+- SED="`which sed 2>/dev/null`"
+- if test -z "$SED";then
+- CWLIB="/usr/local/lib/cw"
+- echo "(NOTE: using static cw library path, this could be invalid)"
+- else
+- CWLIB="`echo \"$0/lib/cw\"|sed \"s/\/bin\/colorcfg//g\"`"
+- fi
++ CWLIB="/usr/libexec/cw"
+ fi
+
+ echo "[ cw library path: $CWLIB ]"
diff --git a/app-misc/cw/metadata.xml b/app-misc/cw/metadata.xml
new file mode 100644
index 000000000000..ffe1cdfd6046
--- /dev/null
+++ b/app-misc/cw/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <upstream>
+ <remote-id type="sourceforge">cwrapper</remote-id>
+ </upstream>
+</pkgmetadata>